WordPress.org

Ready to get started?Download WordPress

Forums

Comments in 1.3-alpha3 (23 posts)

  1. midrangeman
    Member
    Posted 9 years ago #

    I just resynced my WP sandbox to the 1.3-alpha3 level and found that comments are no longer being displayed.
    The comments are there ... I can edit them using the dashboard ... bu thtye are not displayed when the main index or individual pages are displayed.

  2. ysidoro
    Member
    Posted 9 years ago #

    Yes! I have just upgraded from cvs to 1.3-alpha-3 and all my posts says comments(0) , but comments are there throught admin pages.

  3. tedfox
    Member
    Posted 9 years ago #

    I upgraded... no such problems...
    maybe u want to check the coding of index.php?? Maybe they changed the functions..
    (i''ve been upgrading with every alternate nightly... so... can't really point out the differences)

  4. Ryan Boren
    WordPress Dev
    Posted 9 years ago #

    Try replacing this:
    <?php include(ABSPATH . 'wp-comments.php'); ?>
    with this:
    <?php comments_template(); // Get wp-comments.php template ?>

  5. Beel
    Member
    Posted 9 years ago #

    Ryan, I do have that in my index file. I also saved the original beta index and wp-comments files and tested with them -but no go. I'll keep hacking away at this, but if you or anyone else has another idea or two they won't go unheeded while I press on ;-)

  6. Beel
    Member
    Posted 9 years ago #

    Would other 1.3 beta users test something for me (which may be totally unrelated)? Under Options|Discussion are "Allow link notifications..." and "Allow people to post comments..." showing a check mark on update of options?

  7. Beel
    Member
    Posted 9 years ago #

    I think if you de-select them you will not be able to "get them back" without doing it manually. In any event, I submitted a bug report with a klunky fix that worked for me.

  8. midrangeman
    Member
    Posted 9 years ago #

    Ryan:
    I assume the modification you are suggesting is to index.php ... which already has the "<?php comments_template();" statement.
    david

  9. bronski
    Member
    Posted 9 years ago #

    Beel, both default_values are set to open in my nightly 9/7, but nevertheless all new postings have comments and pingback set to closed.

  10. indieb0i
    Member
    Posted 9 years ago #

    Beel, thanks for the SQL command above. I almost freaked out when all of my comments disappeared, but that did the trick.
    As per your other question, after updating the Discussion option page, I lose the checks on those two options no matter what I do. The first one ("Attempt to notify..."), however, can be set and unset.

  11. bronski
    Member
    Posted 9 years ago #

    My guess is that the reason for all my posts showing up with pings and comments closed is a change to xmlrpc.php because when I use the web-interface I can change those back to open, but with desktop applications like ecto that use xmlrpc it doesn't work. I don't remember exactly when it started but I guess it was 8/26 or smth.

  12. ysidoro
    Member
    Posted 9 years ago #

    I have modified template as rboren said.
    I have modified option table 56-57 to "open" as Beel said.
    I have run wp-admin/upgrade.php many times.
    But I continue with "Comments (0)" at my site http://www.pilas.net
    Can you, please, explain me in simple words what steps I need to follow to have comments again? (my language it is not English and perhaps I do not understand all tips).

  13. ysidoro
    Member
    Posted 9 years ago #

    Tks, Beel. I have just check wp_comments table and I confirm that comment_approved is set "1". But I continue with Comments(0)

  14. ysidoro
    Member
    Posted 9 years ago #

    Thank you, Beel.
    Each one of previous comments has comment_aproved=2 in comments table. Yours has 1. Ok, I change all of them to 1. Now all comments are there again!!.
    If I modify template as rboren said http://wordpress.org/support/6/12311#post-73577 I lost my complete comment section under posts, then I leave the previous include statement.

  15. Beel
    Member
    Posted 9 years ago #

    I was just typing a response, out of curiousity what was wrong? update of wp-comments.php?

  16. dylan
    Member
    Posted 9 years ago #

    I hadn't been as vigalant against replacing the <?php include(ABSPATH . 'wp-comments.php'); ?> as I should have been.

  17. Anonymous
    Unregistered
    Posted 9 years ago #

    I am having problems with comments to. The comment approve is set to 1 and I have the correct comment code in the index file. The comments aren't showing up none the less. I am glad it is just a test blog lol. Boy am I glad.
    Still would anyone know how to fix it?

  18. ryoken
    Member
    Posted 9 years ago #

    a link would be nice...

  19. Anonymous
    Unregistered
    Posted 9 years ago #

  20. Root
    Member
    Posted 9 years ago #

    Comments look fine here on FF 1.0

  21. Anonymous
    Unregistered
    Posted 9 years ago #

    Sorry, I went into the database for my main blog with 1.2. Sorry, it works fine now.

  22. justinbaeder
    Member
    Posted 9 years ago #

    Beel, you are awesome.
    For people not familiar with phpMyAdmin, here's what you do (that includes me - I just clicked around until I found it).
    In your webhost's control panel, find phpMyAdmin (in cPanel; It's called DB WebAdmin in Plesk).
    In the left frame, scroll down to wp-comments and click on it.
    In the right frame of the resulting page, click "SQL." A text box will appear, and that's where you can paste the commands Beel said to above. Click "Go," and you're done.

  23. lstelie
    Member
    Posted 9 years ago #

    I encountered this same problem when upgrading from 1.2 to 1.3. Using Beel's command on the database solved it. This step might need to be added to upgrade.php.
    hello,
    Same problem, same solution here, same whish it is included in the upgrade script

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.