WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Comments, I broke it!! (8 posts)

  1. xendistar
    Member
    Posted 4 years ago #

    When I setup my blog (first wordpress site), I did something that broke the comments section of the site. I was not really to worried at the time as I was learning WordPress and building the site. But now the site is mostly built and I want to get the comments working but I am not sure what I did to break it.

    I seem to remember editing one of the php files but which I can't remember, yes I should of made a note but I didn't.

    Anybody help me out with sorting this please?

    My site is http://www.xendistar.co.uk

  2. TransPersonal
    Member
    Posted 4 years ago #

    You probably edited comments.php or the <?php wp_list_comments(); ?> line in single.php. Make sure you have the latter line in single.php and you may want to replace the comments.php with a original copy from the theme you're using. See if that helps.

  3. devicbojan
    Member
    Posted 4 years ago #

    It looks like you have closed comments in Discussion Settings.

  4. xendistar
    Member
    Posted 4 years ago #

    Thanks Transpersonal, I copied the original comments.php from the theme over to the existing one and that seems to have solved the problem. I can't believe how easy it is sometimes, I spent hours looking through the php files trying to find what I had changed :(

    Tim

  5. bcarberry
    Member
    Posted 4 years ago #

    Hi,
    I came across this thread because I broke my comments.php as well! I'm VERY new at this stuff...Can you elaborate on how exactly you replaced the comments.php with an original from your template? I'm using the Default Constructor Theme.

    Specifically I'm am trying to get rid of the 'no comments' 'edit' parts of my Posts - I was successful on the homepage, but not on the other pages.

    Thanks so much!
    Bridget

  6. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    download a new copy of that theme, and replace the comments.php file on your server with the new one from the freshly downloaded theme using ftp, or however you upload wordpress files

  7. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    If you were successful on deleting from your homepage then you must have edited index.php?

    You shouldn't need to edit comments.php BUT most likely you'll have to at least do what you did with index.php to page.php and maybe single.php

  8. bcarberry
    Member
    Posted 4 years ago #

    thank you RVoodoo.

    The problem is i DID edit comments.php and i don't know how to get it back to normal.
    I am getting an error message on my pages now:

    Parse error: parse error, unexpected $ in /home/content/a/k/l/aklebov/html/wp-content/themes/constructor/comments.php on line 62

    http://meatiermedia.com/?page_id=2

    I will download a copy of the theme again like you originally mentioned.

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.