WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Comments Half-Missing in 2.0 Upgrade (3 posts)

  1. Jeff
    Member
    Posted 8 years ago #

    I hope I can explain this clearly, and I apologise in advance for the amount of illustrative code I'm about to post!

    I've upgraded from 1.2 to 2.0 -- most things are working fine. I'm using a custom template that's all in one index.php file. My other two are comments.php and comments-popup.php.

    I've got comments set to pop up, and that works fine, just like it did in the old install. Everything seems to have made the transition.

    When I view a single post, though, the comments do not appear below it, like they used to. On the page, things chop off at the bottom of the post: "Filed under CategoryName | " (After the | is where the % Comments line would appear.)

    Here's what's going on in the code, in case that might help to clarify matters. In index.php, the chunk in question looks like this:

    <div class="feedback">
    [WP category code snipped!] | <?php comments_popup_link('Add your comment!','1 comment','% comments','comment','Comments (off)'); ?>
    </div>
    <?php trackback_rdf(); ?>
    <?php comments_template(); ?>
    </div><!-- end post div -->

    It seems to be picking up the trackback_rdf() line ok -- in an actual page, the code becomes:

    <div class="feedback">
    Filed under: [WP category stuff snipped!] | <a href="http://ferrellweb.com/wp/?comments_popup=109" title="[Title snipped!]">Add your comment!</a></div>
    <rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
    [Etc. - trackback snipped!]
    </rdf:RDF></div>

    So it looks like to me that comments_template() isn't processing, or is coming up blank. Does *anybody* have a clue how I can get this working again?

    Thanks!
    Jeff.
    (Oh -- the site's at http://www.ferrellweb.com/wp right now, if looking helps any!)

  2. Mark (podz)
    Support Maven
    Posted 8 years ago #

  3. Jeff
    Member
    Posted 8 years ago #

    Thanks! Everything's cool now. I had bungled my upgrading, so I started back at square one.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.