WordPress.org

Ready to get started?Download WordPress

Forums

P2
[resolved] Comments get assigned to the wrong posts (7 posts)

  1. Elmastudio
    Member
    Posted 1 year ago #

    I'm having the problem that comments on my blog using the P2 theme get assigned to the first post automatically (instead of the correct post) if someone comments on any post directly from the blogs home page (I have toggle comments active). I researched already for answers but couldn't find anything.

    I think I have no special plugins or something installed, that could cause this problem. Does anyone have a suggestion ot solution?

    Thanks!

  2. Elmastudio
    Member
    Posted 1 year ago #

    For everyone with the same problem: I had Jetpack comments active and this was causing the problem. Since I deactived Jetpack comments everything works great again.

    Best, Ellen

  3. coennaninck
    Member
    Posted 7 months ago #

    I have the same problem and finally figured out it was Jetpack Comments. I logged my issue here: http://wordpress.org/support/topic/comment-posted-to-wrong-blog-post?replies=1

    Basically I can't use this feature. Maybe it messes things up when a blog already has existing comments made when this plugin did not yet exist.

    At any rate, it's a serious issue and hope it will get fixed at some point.

  4. justinlong
    Member
    Posted 7 months ago #

    It's a problem on my blog as well (justinlong.org); I'm trying to figure out how to disable Jetpack Comments but not Jetpack as a whole.

  5. coennaninck
    Member
    Posted 7 months ago #

    Hey Justin,

    Here's how to leave everything on that Jetpack offers but only disable Jetpack Comments:

    1. Click the Learn More button on the left side. Notice that the Configure button changes into Deactivate.
    2. Now click the Deactivate button (that was previously named Configure).

    Jetpack Comments are now disabled while the other features are still enabled.

    Let me know if you run into more problems.

  6. justinlong
    Member
    Posted 7 months ago #

    Ah, thanks. That helped. I finally saw the Deactivate button.

  7. coennaninck
    Member
    Posted 7 months ago #

    You're welcome and glad it helped!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags