WordPress.org

Ready to get started?Download WordPress

Forums

Comments form disappeared from page (9 posts)

  1. pippoflash
    Member
    Posted 8 years ago #

    Hello,

    Suddenly comments form disappeared from my post pages.
    Maybe it's due to some tweaking of the template, but I didnt change anything related to coments...

    Also posts which have comments already posted and approved, when I click on "comments (1)" it goes to an anchor in the page "#comments" which doesn't exist...

    Thank you very much,
    Pippo
    http://www.pippoflash.com

  2. skulled
    Member
    Posted 8 years ago #

    What did you change in the theme?

    It seems that you forgot to put in the comments template tag on your single.php page, from the looks of it.

    Please check your single.php file, and compare it to the "default" theme single.php file, you should see the different and a piece of code along these lines <?php comments_template(); ?>

    Hope that helps.

  3. pippoflash
    Member
    Posted 8 years ago #

    In my template there is not a single.php file :(
    Here are all the files I have:

    comments.php
    comments-popup.php
    footer.php
    gravatar.php
    header.php
    index.php
    page.php
    sidebar.php

    Could it be the page.php?
    When I change this, it both affects the home page with post listing, and the single post view...

    thanx!

  4. skulled
    Member
    Posted 8 years ago #

    What theme are you using, the original one before you modified it?

  5. pippoflash
    Member
    Posted 8 years ago #

    Daisy Rae Gemini

  6. pippoflash
    Member
    Posted 8 years ago #

    I also tried disabling all plugins, but no help...

  7. pippoflash
    Member
    Posted 8 years ago #

    In the main page template, I have wrapped the comments_template() function in this way:

    <!-- COMMENTS DOWN HERE -->
    <?php comments_template(); ?>
    <!-- COMMENTS UP HERE -->

    And on the output, in the page source, it shows:

    <!-- COMMENTS DOWN HERE -->
    <!-- COMMENTS UP HERE -->

    So apparently the comments_template() function returns nothing...

    oh gosh...

  8. skulled
    Member
    Posted 8 years ago #

    A lot of posts have been made about comments stored prior to the upgrade not showing up etc ..

    I am not entirely sure if its a bug in the code, and if a patch has been submitted yet.

    I suggest that you search the forums for comment issues with 2.0 (if the search works, because its giving me a page not found right now :)), or perhaps wait a bit more ..

  9. pippoflash
    Member
    Posted 8 years ago #

    Thank you, I am still using 1.5, and comments used to work untill a few days ago :(
    I didnt make big changes, except installing a few plugins. But I removed them all and still doesnt work...
    I have no idea why comments_template() returns nothing...
    I'll wait for more luck...
    thanks a lot skulled!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags