WordPress.org

Ready to get started?Download WordPress

Forums

Comments Feed has stopped validating (6 posts)

  1. rreiter
    Member
    Posted 5 years ago #

    I have recently updated two different blogs to WP 2.7. Both are running on separate sites with different themes.

    In both cases the Comments RSS feed no longer validates. When I submit my feeds for validation, I get the same error:

    XML parsing error: <unknown>:18:51: not well-formed (invalid token)

    Both were working prior to the update. Is there any possibility that it is a problem in the new coding?

    Any help would be appreciated.

  2. rreiter
    Member
    Posted 5 years ago #

    More Information...

    In both cases the blogs are in a sub folder of a site. The feed validator lists the LAST LETTER in the sub folder as the problem

    For example, the "S" in members is listed as the issue below:

    <link>http://www.ncgangs.org/members/?p=979&cpage=1#comment-15</link>

    Also the "G" in blog is listed as the problem below:

    <link>http://www.lifeatantioch.org/Pastors_Blog/?p=130&cpage=1#comment-80</link>

    Both are RSS 2.0 feeds.

  3. rreiter
    Member
    Posted 5 years ago #

    I have even tried copying and pasting the code for adding a feed to your side bar from the codex page. First, the html code was not displaying correctly in the side bar.

    When I clicked on the new link, I got a 404 error that said that the sub folder that the blog is installed in could not be found. The only thing I noticed, was that there was an additional "<" after the folder name:

    /folder_name/<

    It honestly looks like there may be a bug in the code that does not like the fact that the blog is installed in a sub folder. Any suggestions?

  4. tin68
    Member
    Posted 5 years ago #

    After upgrading my blog to 2.7 I have exactly the same problem with comments rss feed. And WordPress is installed in a subfolder as well.

    http://www.blogkom.net/wp/?feed=comments-rss2

  5. tin68
    Member
    Posted 5 years ago #

    Found a patch

    http://trac.wordpress.org/ticket/8405

    Here it works now.

  6. rreiter
    Member
    Posted 5 years ago #

    Thanks! Solution works great!

Topic Closed

This topic has been closed to new replies.

About this Topic