WordPress.org

Ready to get started?Download WordPress

Forums

Comments Error (8 posts)

  1. CyrilJones
    Member
    Posted 8 years ago #

    Hello!

    On my site I have 2 problems...
    One: When you click on No Comments nothing shows up. So users cant post a comment at all? Why is this!? And how do I make them post a comment again?

    Second: I actually want to try and make Guestbook page just by making one post people can leave a comment on.
    But how do you enable comments of being directly displayed and how do I link to specifically one post?

    Or do I need to make a page of some sort?

    Thanks!

    P.S. If you dont understand something I asked just tell and I will try to clear it up!

  2. Austin Matzko
    Member
    Posted 8 years ago #

    A lot of this depends on what theme you're using. Can you tell us what it is or link to your blog?

    For the second issue, I recommend creating a page, naming it "Guestbook," and allowing comments. Again, some themes do not allow comments for pages by default, so we would need to know what theme you're using to determine whether that will work.

  3. Chris_K
    Member
    Posted 8 years ago #

    His name link is his blog it would appear. And, at a guess, his theme is missing some pages. Clicking a post title doesn't result in a single post page (single.php ?) which is where those comment links want to go as well.

    I'd suggest reloading the theme from the original archive (back up any changes first, of course) to make sure all of the theme pages are installed in the proper theme folder.

  4. jackosh
    Member
    Posted 8 years ago #

    You should have two files in your "theme" folder. The first is comments.php and the second is single.php. Without them, no one will be able to post comments to your site.

  5. jackosh
    Member
    Posted 8 years ago #

    OK, I see the problem now... when you click on the "comments>>" link, it just changes the address bar to "http://www.noordkopwaterpolo.com/#respond" no matter what post you click on. Instead, you need to edit your index.php file so that when someone clicks on the comments link, it links to "http://www.noordkopwaterpolo.com/?p=[POST NUMBER]#respond".

    Here is how to do it...

    Change whatever code you currently have in your theme as the comments link to: <?php comments_popup_link('No Comments »', '1 Comment »', '% Comments »'); ?>

    That should solve all of your problems. If you have trouble understanding my directions, just post again and I'll see it.

  6. iand
    Member
    Posted 8 years ago #

    A theme will work without single.php provided it was intended to (cf. classic theme). Likewise, if there is no comments.php file, the one from the default theme is called (I think).

    Anyway, Looks like it might be permalink issue as the comments, archives, and category links are wrong too. Try setting permalinks to the ?p=123 format, updating, then putting them in the /%year%/%monthnum%/%day%/%postname%/ format and updating again.

  7. CyrilJones
    Member
    Posted 8 years ago #

    Hey Guys thanks for all the help but I still didnt figure it out. I use the boredom theme by the way and my blog is: http://www.noordkopwaterpolo.com .

    I have my permalinks set up custom with just a / .
    Because if you look at my menu, I dont want strange numbers and stuff when people click on the pages in the menu...

    I hope somebody can help me :).

  8. Chris_K
    Member
    Posted 8 years ago #

    I have my permalinks set up custom with just a / .

    Bingo. There's your problem.

    At least add the post slug to that.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.