WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Comments don't work. (5 posts)

  1. MrGunn
    Member
    Posted 7 years ago #

    When anyone, user or admin, tries to leave a comment, the comment box loads, but the "submit comment" button simply brings them to a blank page at http://synthesis.williamgunn.org/wp-comments-post.php

    I've reset my blog to the default theme, disabled all plug-ins, deleted .htaccess, changed permalink style to default, and then rebuilt the permalink structure, after deleting the .htaccess file.

    None of that changed the behavior at all.

    I have groups of entries such as the following in my server logs:

    129.81.225.212 - - [27/Jun/2007:13:16:28 -0700] "POST /wp-comments-post.php HTTP/1.1" 301 624 "http://synthesis.williamgunn.org/2007/06/27/google-documents-and-wordpress/" "Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4"
    129.81.225.212 - - [27/Jun/2007:13:16:28 -0700] "GET /wp-comments-post.php HTTP/1.1" 200 364 "http://synthesis.williamgunn.org/2007/06/27/google-documents-and-wordpress/" "Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4"
    129.81.225.212 - - [27/Jun/2007:13:16:31 -0700] "GET /wp-comments-post.php HTTP/1.1" 200 364 "http://synthesis.williamgunn.org/2007/06/27/google-documents-and-wordpress/" "Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4"

    So it's a 301 moved permanently, then one 200 OK status code for every time I press load /wp-comment-post.php

    If I FTP to my site, then delete wp-comments-post.php, I get a 404 error when I hit the "Submit comment" button.

    I don't understand why I get the 301. I don't really understand what a 301 is, and in what cases that code would be returned instead of a 404.

    I don't think it has anything to do with URL rewriting, because it happens whether it's on or off.

    In summary, I've reset my blog to the most generic, default configuration, and it still doesn't work, and I think it has something to do with the 301 http status code, but I don't really know.

  2. drmike
    Member
    Posted 7 years ago #

    Actually you get a 405 error when you leave a comment.

    I'm wondering if it's because you've got the 'www' bit in your blog's URL. That's incorrect as the 'synthesis' bit takes hte place of it. I know in the *.com, it's actually not allowed. I wonder if under the *.org it is as well.

    I'd try removing the 'www' bit out of your site URLs and give it a second try.

  3. MrGunn
    Member
    Posted 7 years ago #

    drmike, you're saying I should change my domain settings with my host to require www. not be present, rather than allowing either as I currently have it?

    I'll try that.

  4. MrGunn
    Member
    Posted 7 years ago #

    Well, I actually have my domain set to "Remove "www." if somebody goes to http://www.domain.com/".

    There's no www in the URL, not in the browser nor in the logs. Surely you must have meant something else?

    Ahh! Under Options>General in wordpress admin I did have www as the wordpress address and the blog address. I changed that and what do you know....It Works!

  5. drmike
    Member
    Posted 7 years ago #

    Cool.Just for reference, unless the DNS server is really mucked up, both with and without will resolve to your blog. If you have the 'www' in there, it forces folks to use it and that doesn't always happen as you see.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags