WordPress.org

Ready to get started?Download WordPress

Forums

Comments do not appear to be working (since upgrade to 1.5) (66 posts)

  1. ajlitton
    Member
    Posted 9 years ago #

    For me, the upgrade went painlessly until I completely embraced the themes. I split my Index page into Header, Footer Sidebar etc. Then my comments stopped working - nothing shows up. I tried replacing the comments.php file with the default, but it made no difference. My comments.php file worked fine before, and it still works fine on my single.php page.

    Is it something to do with calling it mulitiple times on the page? I don't like using the popup. I use ScriptyGoddess' show/hide comments, which works fine. _Worked_ fine. I've tried the other suggestions in this thread (those I understood). Anybody?

    Anybody?

  2. locomote
    Member
    Posted 9 years ago #

    More of us with the same problem - no field to input name/email: http://wordpress.org/support/topic.php?id=24695

    No solution yet~

    One thing...I installed the "GreenTrack" theme, and my comments work no problem, but in "default" and a couple others, it doesn't work...

  3. gallilaw
    Member
    Posted 9 years ago #

    The problem may or not be related to the mysql data base.

    I have found that by dropping the tables from the data base and "reinstalling" -- just by running install.php over the old system -- I can get the comment function to work, at least temporarily.

    Will have to keep testing to see if it breaks again.

    Good luck.

  4. jonnyboy
    Member
    Posted 9 years ago #

    "An original posting is accompanied only by a "0 comments" link. Click it and you get a comment posting box. Fill it in and submit, and the page pretty much recycles."

    This is exactly what happens to me. Went from 1.2.1 to 1.5 - tried backing up the database and restoring it. Fresh install with a new database is fine; as soon as I import my old, new comments continue to be impossible.

    Any progress?

    http://www.ohjon.com

  5. jonnyboy
    Member
    Posted 9 years ago #

    Any developers looking at this problem?

  6. ajlitton
    Member
    Posted 9 years ago #

    I've solved my problem, but there seem to be a number of different ones here so it probably doesn't matter much. Mine was that when I split my old index page into Header, Sidebar etc. the comments stopped displaying - comments_template(); did nothing.

    The solution was to take the line $withcomments=true; out of the header.php file and put it in the index.php file.

    I hope this helps somebody.

  7. ajlitton
    Member
    Posted 9 years ago #

    (Sorry - accidentally double posted).

  8. litlnemo
    Member
    Posted 9 years ago #

    There definitely seems to be more than one problem going on to cause this. I hope some people in the know are actually troubleshooting this.

    In our case the problem was solved by making sure that the Blog Address and WP Address was the same -- my blog is in a subdirectory. And I am seeing other problems besides this one that seem to indicate that WP 1.5 has issues with blogs not being at a particular location. So I think there's probably an overall issue or two that need to be fixed, that might contribute to fixing a lot of these other problems people are seeing. Unfortunately I am not skilled enough to figure it out myself.

  9. jonnyboy
    Member
    Posted 9 years ago #

    Hmm. My blog is in the root directory; I think it's a database problem, because a fresh database works fine with the same install... just the upgraded/updated one fails to record new comments.

  10. omar
    Member
    Posted 9 years ago #

    Any chance that there is a developer even looking at this issue? I'd feel a bit better if one of the guys would weigh in even if it is to say "I'm looking into it".

    This silence is scary.

  11. jafer
    Member
    Posted 9 years ago #

    My comments are not working either now. I'm wondering if I got blocked because I put a spammer into that list in my options - the one below where you can add spam words. I put in http://www.spammer.com and I'm wondering if it is reading part of the url and blocking everything from the comments. I know it said that it could use part of the word, but I wasn't thinking at the time that it could take www perhaps instead of the whole url as one thing.

    If this is the case, where can I edit that list - that is the only one I added to it and I'd like to remove it to see if the comments will work again.

    Thanks for your help.

  12. bethchelle
    Member
    Posted 9 years ago #

    My installation was a fresh install since I just began using WP. I had 2 different spam plugins activated-I inactivated one-now my comments work? So if you're having problems, and have spam plugins activated-try inactivating and see if this solves any problems.

  13. jafer
    Member
    Posted 9 years ago #

    I didn't activate any spam plugin, I put the url into Comment Blacklist under Options -- Discussion.

    I have the following plugins activated: Auto-Close Comments (after 5 days), Customizable Post Listings, Gravatar, Who is Online, Recent Comments, Content Show/Hide with javascript, and WP Plugin Manager.

    Could someone tell me where I can edit that blacklist in case that's the problem?

  14. davincim
    Member
    Posted 9 years ago #

    So THIS is the train I should have been on. ;-)

    Man, this has been frustrating, BUT I think I'm making progress due to the comments made here. I decided to delete my .htaccess file (updated the permalink structure with nothing in the file), and I was able to get to and make a comment.

    However, I'm still not seeing the fields for name, email and URL. Is there a fix for that?

  15. jafer
    Member
    Posted 9 years ago #

    The comments were working up until I added that spam site to the blacklist, that's why I'm thinking that that's what caused it.

    However, I'm open to other fixes... although I've tried everything suggested in this thread.

    I just checked in phpadmin and saw that all the "test" comments that I've put up there, are showing up as spam under the 'comment-approved' column. So it seems they have automatically been relegated to spam, cuz I didn't mark them in the 'awaiting moderation' spot, and they never showed up anywhere else - other than in my db table.

    Again, I think I need to edit that comment blacklist - can anyone tell me where to do it?

  16. davincim
    Member
    Posted 9 years ago #

    jafer - are you referring to the wp-blacklist plug-in?

  17. locomote
    Member
    Posted 9 years ago #

    Well - If someone has found an answer, I'm still lost as to what it is.... -_-;; I guess some people have said something about playing with your database will help things? What do you mean? Just create a whole new database and delete the old one? I don't know anything about MySql or databases in general, so that just doesn't sound like something I want to do unless someone with authority explicitly says that's the right thing to do.

    I'm with omar -- it seems like a pretty widespread problem. Why isn't anyone who actually does know what they're doing at least looking into it?

  18. davincim
    Member
    Posted 9 years ago #

    @locomote,

    I'm not exactly sure what the problem was for me, but I did a fresh reinstall earlier today and it seemed to be working. I don't know, maybe I missed a step the first time around. I don't know if this is related, but I think I may have missed the instruction on copying over my wp-config.php file into the new uploads.

    Anyway, please refresh my memory: is your problem not showing comments at all or are the name, email and URL fields not showing up? I experienced both, but the latter was what confused me until I logged out (the only option there). That's when I figured out that's what first-time visitors saw. Just before the upgrade, I had the option of seeing those fields.

  19. locomote
    Member
    Posted 9 years ago #

    Thanks for helping davincim

    My specific problem is this:

    In the "default" template, the name, email and URL fields do not show up at all. IF I am logged in, then it says "You are logged in as Loco Mote. Logout>>". IF I am not logged in (other readers), it says "You are logged in as . Logout>>".

    Because of that, I changed to the GreenTrack theme, which now provides the fields to enter that information. If I am logged in, then there is no problem. If I am not logged in, I fill in all the information, but then when I click "submit comment", it then refreshes the screen with the email set as "user@wordpress.org" and the other fields blank. The comment actually goes through, but the name is "anonymous", the email is "user@wordpress.org", and the website URL is blank (I had filled in all fields).

  20. davincim
    Member
    Posted 9 years ago #

    Sorry, buddy. I'm at a loss. Maybe some of the heavyweights here and lend a hand. Good luck! :)

  21. locomote
    Member
    Posted 9 years ago #

    Thanks for NOTHING~!!! (haha j/k~ Thanks a lot for trying ^__^)

  22. Wanbro
    Member
    Posted 9 years ago #

    locomote - sounds like I have pretty much exactly the same problem as you...

    not that I can help - but just so you know you're not the only one...!

  23. kabitzin
    Member
    Posted 9 years ago #

    For those of you with blank comment pages, does it maybe have something to do with the CHMODE access of your comments page?

    I am also having a problem with my comments since when commenters type in their name and email into the comments fields, the email portion gets mysteriously stripped out and shows up as blank even in the admin/manage pages. This is with WP 1.5 and with a different template than the default or classic.

  24. locomote
    Member
    Posted 9 years ago #

    What should the CHMOD be? I checked for my comments.php under the default theme, and it's 666. Satan himself must be causing the bug...

  25. jonnyboy
    Member
    Posted 9 years ago #

    Could it be related to the Permalinks/archives/.htaccess ?

    I tried logging out, but I still see the comments box/username/etc. Comments seem to submit, the page resets, but nothing shows up as usual (whether logged in or anon).

    Jon
    http://www.ohjon.com

  26. locomote
    Member
    Posted 9 years ago #

    *bump* -- as far as I know, still no answer....

  27. vkaryl
    Member
    Posted 9 years ago #

    My issue (which actually encompassed several of those posted in this thread) was caused entirely by a mistaken entry in the .htaccess file. You should definitely verify every line in the file. While the line I blew was easily found, YMMV, and perhaps you should delete whatever's there and start over with a fresh "blank slate". I have noted previously that someone like me who has very little real knowledge of apache et al can very very easily blow the simplest addition to the .htaccess. Had it not been for someone I "know" on another forum, I would probably still be struggling with this.

  28. locomote
    Member
    Posted 9 years ago #

    Wait - maybe there a bit of an answer... I think deleting this code might do the trick. Check:

    http://www.davejenbarnes.com/wordpress/?p=320#comment-712

    I don't like the fact that you have to delete from the main WordPress code, but it seems to do the trick...is it just a genuine bug in the code?

  29. vkaryl
    Member
    Posted 9 years ago #

    I couldn't say - I did read that post, but didn't have to follow her instructions for deleting that code section in order to get mine working again. I think from various posts I've read here lately that yes, her "tweak" does help some people.

  30. jonnyboy
    Member
    Posted 9 years ago #

    I tried her remedy, and it didn't work for my problem.

    Ugh. Can we get a developer to highlight this as a problem? I don't want to lose my old posts, but it is really dissapointing that no one can comment on new posts.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.