WordPress.org

Ready to get started?Download WordPress

Forums

Comments do not appear to be working (since upgrade to 1.5) (66 posts)

  1. xarquid
    Member
    Posted 9 years ago #

    http://www.deadafterdark.com/xarquid/wordpress/

    When going into a comment page it brings up the archived version of the post with the options near the bottom to make a comment -- after I click the "leave a response" link nothing appears to happen. I followed the instructions on how to upgrade very closely so I don't think I did anything wrong there. I can't figure out what is going on and all of the other posts about comments not working when upgrading seem to be related to the popup comment box -- which I never had enabled in the first place.

    Any ideas on how to get comments functioning again?

    The file names in my kubrick theme directory (which is enabled) is comments.php and I went ahead and tried to copy it to a new file, wp-comments.php, and upload it and see what happens...but it didn't work either.

    Thank you.

  2. Michael Adams (mdawaffe)
    Member
    Posted 9 years ago #

    Are they showing up in your Awating Moderation list?

  3. xarquid
    Member
    Posted 9 years ago #

    Nope, I disabled all of those features.

    Under OPTIONS/DISCUSSION I made sure:

    # An administrator must approve the comment (regardless of any matches below)
    # Comment author must fill out name and e-mail
    # Comment author must have a previously approved comment

    Were all disabled/unchecked.

    I can't even get the comment box/form to come up for me on my own page. It just doesn't load or do anything when I click that link.

    In 1.2.2 I used to click on the NO COMMENTS (or the amount of comments) and it would immediately come up with the comment form by using the goto (#comments) function, I believe. Now I can't even get the form to appear using any of the links.

  4. xarquid
    Member
    Posted 9 years ago #

    Fixed it. I just enabled the new default (kubrick anyways) and copied over my images...I think it had something to do with the way it handled headers in 1.5....either way it is working now!

    Thanks for your help.

  5. Michael Adams (mdawaffe)
    Member
    Posted 9 years ago #

  6. Michael Adams (mdawaffe)
    Member
    Posted 9 years ago #

    Ah - good work :)

  7. xarquid
    Member
    Posted 9 years ago #

    Thanks for your help :)

  8. Michael Adams (mdawaffe)
    Member
    Posted 9 years ago #

    It could have been what I was blithering about here:
    http://wordpress.org/support/topic.php?id=23495#post-132916
    (it turns out, though, I was off-topic - the rest of the post is about something else).

    On your old comments.php, was there an include statement for wp-blog-header? It'd be good to know if that was the problem.

  9. darusha
    Member
    Posted 9 years ago #

    I had the same problem. My old commments.php file did not have an include statement for wp-blog-header, but it just did not work. I replaced it with the comments.php file from the default theme, and voila! problem solved. So, if comments are the only broken part of your theme, try changing the comments.php file (backup your old one just in case, though).

  10. miaow
    Member
    Posted 9 years ago #

    I thought everything had gone smoothly with my upgrade to 1.5, but I am having the same problem with comments. I have tried copying over comments.php from the Classic theme folder to my Carrots (nice one!) folder - but it hasn't fixed it, and now I think I can definitely say... I'm stuck!
    :o(
    http://www.miaowthecat.com

    Oh. And in my old comments.php there is no mention of wp-blog-header.

  11. klinder
    Member
    Posted 9 years ago #

    I am having the same problem. I just did a fresh install of WordPress but can't get comments (even the example one that comes with the fresh install) or the comment form to display. I have downloaded, installed and tried various other themes but with no luck. Am I missing something? Anyone have any ideas or suggestions?

    I am using IIS and have gotten permalinks working. This is the only major thing left (well other than the inability to do file editing with the admin - but that's minor and probably due to my hosting being on windows) and could really use some help or suggestions.

  12. elvenbook
    Member
    Posted 9 years ago #

    I've had the same issue, but I've just replaced my comments.php by the default one, and it works !
    if your are logged as admin or member, there is just a "leave a message" box (no email required, no url) but if you want to comment without being a member, you will have to enter your name, url and email (according your admin configuration)
    It works fine now !!!
    I'm also able to view my old comments !

    I hope this helps !

  13. pt49
    Member
    Posted 9 years ago #

    Comments worked fine for me right from when I updated from 1.2.1 to 1.5, including all my old comments and a few spam comments that were awaiting moderation!

  14. miaow
    Member
    Posted 9 years ago #

    No - I've tried replacing from the 'Classic' themes folder and the 'Default' folder and have had no luck. I am completely without comments. I can see if a comment has been left, but if I click on 'comments' it reloads the page in question and comments don't appear - it's like they're not even activated. I have no idea what to do.

  15. ReCk
    Member
    Posted 9 years ago #

    Ok i have done everything that has been suggested and i cant get my comments working again. I did a search within both the themes and neither has a wp-blog-header in it.

  16. davidmsc
    Member
    Posted 9 years ago #

    Just adding my two cents: did an upgrade to 1.5 (from 1.2) with no apparent problems...but comments don't seem to be working with some Themes (bionic), but do work with others (default). But even when comments do work, the # of comments still shows as "0" on the main page.

    Ideas?

  17. ReCk
    Member
    Posted 9 years ago #

    I just tried a fresh install and it works fine, but if i drop all the tables and insert all the tables from my backup the comments dont work anymore, is there a difference in how 1.5 calls comments from the database.

  18. Anonymous
    Unregistered
    Posted 9 years ago #

    my comments don't work at all, in any theme.

  19. ReCk
    Member
    Posted 9 years ago #

    Ok i have narrowed it down to something being wrong within the option table in the database.

    I drop table by table and replaced it with the backup and only when the option table was inserted did the comments stop working.

    Does any have any ideas of what would be causing this.

  20. ReCk
    Member
    Posted 9 years ago #

    Okay, i dont know if this would cause the problem but the table strutures are different from 1.2 to 1.5, in 1.2 in the comments table USER_ID was 4th from the bottom, but in 1.5 it is last. this might be casuing the problem.

  21. Anonymous
    Unregistered
    Posted 9 years ago #

    i have a possible solution after a full night of troubleshooting. after several clean installs of 1.5, my comments would not work at all. i finally decided to delete the blank index.htm file from root directory (i kept it there to hide my work in progress). comments work perfectly now.

  22. ReCk
    Member
    Posted 9 years ago #

    Wow nice find, but now i am stuck, my word press install is in a subdomain, i used ,htaccess to redirect to the subdomain.

    I removed the redirect and everythign works fine, I then tried to use a simple html page with a meta re-direct, and now the comments dont work again. So for wordpress to work it needs to be in root.

  23. Anonymous
    Unregistered
    Posted 9 years ago #

    that's the theory i'm leaning toward. perhaps a server guru will drop a final solution on us.

  24. litlnemo
    Member
    Posted 9 years ago #

    I thought I posted a reply to this earlier, but it's not here... maybe I posted to another thread and can't find it now... anyway, WP runs fine in a subdirectory -- it's just that in Options>General, the WordPress address and Blog address now apparently have to be the same. Which is a bug, I think.

    My blog is in a subdirectory (http://slumberland.org/wp/), but the Blog address used to point at root (http://slumberland.org/), because there's an alias there that sends people to the blog directory. And when I ping Pingomatic and other similar services, I ping them with the http://slumberland.org/ address, because that's the address I've used for years and the one with which I'm listed on most people's blogrolls. So the old way this used to work was fine. But now that I have to set the WP Address and the Blog Address to be the same, the automatic pinging no longer pings the correct address. For the time being I am manually pinging.

  25. ReCk
    Member
    Posted 9 years ago #

    Nope that doesnt fix it

  26. lauch
    Member
    Posted 9 years ago #

    I am having the exact same problem. Posts display, but do not offer any place to make a comment. The only thing I see is an "edit" which you can edit the post with. I am relatively new to WordPress, and have been trying to tweak the code.

    The best way, which isn't exactly a pretty way of doing it, is to grab index.php from the classic theme and copy it over. From there, you can tweak it to get it looking right.

    Hopefully, this will fix your problem.

  27. ReCk
    Member
    Posted 9 years ago #

    I was able to get mine working by using a javascript to redirrect my domain to my subdomain and it seems to have fixed the problem.

    Thats to all the suggestions

  28. davejenbarnes
    Member
    Posted 9 years ago #

    I have the lack of fields syndrome. . . . users seem to have problems posting because the email and name fields are required but don't show up for them... I think it has something to do with WP thinking they're logged in as admin, but they're not! AAAAAHHHHHH soooo frustrating! And I'm a php noob so I don't know how to fix the stupid thing!

    -Jennifer

  29. gallilaw
    Member
    Posted 9 years ago #

    Same problem here. Have re-installed the script files, and have used several themes including the defaults. Have made it as easy as possible for someone to post -- no limits. Have tried to post as admin and as a registered user.

    An original posting is accompanied only by a "0 comments" link. Click it and you get a comment posting box. Fill it in and submit, and the page pretty much recycles.

    Have never been able to see a comment, or get one recognized by any part of the management console.

    Spen a lot of time learning the new design features; never thought a problem like this would make the blog unusable.

    Help would be nice... but I see a lot of other folks are stumped.

    By the way.... is it possible for a registered user in this discussion forum to change his password?

  30. lokrin
    Member
    Posted 9 years ago #

    The comment box comes up. If I just click on the submit button I get:

    Error: please type a comment. on a completely blank page.

    Otherwise I just get a totally blank page.

    Both times the page in the address bar is:

    http://weblog.lokrin.net/wp-comments-post.php

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.