WordPress.org

Ready to get started?Download WordPress

Forums

Comments disabled on posts (13 posts)

  1. wpdools
    Member
    Posted 5 years ago #

    Hello, somehow in the last day or so, comments were disabled on each individual post that I've created over the past couple years. On the Advanced Options under each post, the setting Allow Comments has been unchecked on each post. Any idea how to globally reset that to checked (Allow comments).

    Note: I noticed that under Settings-Membership, the field 'Users must be registered and logged in to comment' was enabled as well. I unchecked this box, now new posts allow comments. But all previous posts have comments disabled. Any thoughts?

  2. Pavlos
    Member
    Posted 5 years ago #

    The exact same thing happened to me.

    1) Somehow the "Users must be registered and logged in to comment" option was checked on it's own.
    2) Each Post has "Allow Comments" unchecked (although they previously allowed).
    3) All my posts now say "comments closed"...

    All this after I upgraded to 2.6.2. Any idea what caused it yet? Or how to set all posts to allow comments again? It seems unchecking the "User must be registered..." option does not help with older posts. Thank you!!

  3. wpdools
    Member
    Posted 5 years ago #

    Pavlos- yep, that's me to. Wondering if some combo of the 2.6.2 upgrade and a plugin perhaps caused this!

  4. Pavlos
    Member
    Posted 5 years ago #

    This is the most likely case. It must be one of the plugins, in combo with 2.6.2. A solution I found to set the comments on all posts back to "allow" is the following.

    1) You must have access to use SQL commands on your database, like for example with phpMyAdmin.
    2) Select your WP database and click on the SQL tab.
    3) Paste and run the following SQL command.

    UPDATE wp_posts SET comment_status = 'open', ping_status = 'open' WHERE comment_status = 'closed';

    I hope this helps. It will save you the time from having to visit every single post and check it to have comments allowed again.

    If anyone figures out what caused this, I would like to know please! So to prevent it from happening again. Good luck!

  5. wpdools
    Member
    Posted 5 years ago #

    Thanks man. That did the trick. I still haven't figured it out but it's definitely a plug in in combo with 2.6x. I just deactivated then reactivated all my plugins and the same thing happened.

  6. andrusk
    Member
    Posted 5 years ago #

    Happened to me also at globalmotors.net

    How can I access the SQL commands?

  7. andrusk
    Member
    Posted 5 years ago #

    Figured it out and it works now.

  8. DogRatCom
    Member
    Posted 5 years ago #

    Thanks very much. Worked like a charm. I'm still on 2.5.1 and my problem was exactly as described above. Wonder what caused it?

  9. filmfan214
    Member
    Posted 5 years ago #

    Thank you so much! That was quite an annoyance.

  10. frankcswain
    Member
    Posted 5 years ago #

    Thanks, worked for me.

  11. gymgangsta
    Member
    Posted 5 years ago #

    Thanks Pavlos, that worked!!!

  12. simplemortaldada
    Member
    Posted 5 years ago #

    Hi. I'm using WordPress 2.7 in my site http://alerta.pe.
    Now I have only 2 posts, and Comments were working ok until yesterday.
    Today, if I click the link to give a comment I obtain this message:

    Not Found
    The requested document was not found on this server.
    Web Server at alerta.pe

    In both of those posts it is checked the option "Allow comments on this post".

    ┬┐What can I do? I didn't activate any plugin. Thnaks a lot...

  13. davidallred
    Member
    Posted 5 years ago #

    Thanks a ton Pavlos! That worked for me as well. It would be nice if someone actually knew the cause of it to avoid this from happening in the future.

    Thanks again!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags