WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Comments disabled in Gallery (5 posts)

  1. ColletteCM
    Member
    Posted 11 months ago #

    I am running a portfolio website for photography and don't want random viewers to be able to comment on anything. If they have feedback or inquiries I only want to be contacted through my email on the contact page so I have tried to remove that feature throughout the website. For some reason putting in the code into style.css didn't work when it worked just fine on another website, so I assume it has something to do with the theme I am using (snapshot). I haven't received a response from the creator and this needs to go live within the week so I am desperate. I installed a plugin and it seemed to work until I click on a picture in one of my galleries and there there it is again- the ability for someone to comment, and even like on facebook, tweet, share photos, etc. I really don't want this and can't figure out how to remove it permanently from every aspect of my site. Please help!

  2. ColletteCM
    Member
    Posted 11 months ago #

    Also, when I go into edit my gallery I don't see any way to choose whether or not I want comments disabled. Maybe I am missing something very small?

  3. WPyogi
    Volunteer Moderator
    Posted 11 months ago #

    For each gallery page, click on the "quick edit" under that page - a drop down opens - where you can uncheck "allow comments." That will remove the comments section on the gallery page.

    To remove from a single page photo page, add this to your custom CSS:

    #single-comments-wrapper {
        display: none;
    }
  4. WPyogi
    Volunteer Moderator
    Posted 11 months ago #

    If the first instruction above does not work for you, try adding this to your CSS:

    #respond {
       display: none;
    }
  5. ColletteCM
    Member
    Posted 11 months ago #

    Thank you! I actually ended up using a plugin but it still displays "no comments" up above and appears to be clickable even though it doesn't do anything. I will try this to see if that clears it.

    [Second moderator note: Please do not post in someone else's thread unless you are contributing towards their issue. If you are not satisfied with the level of support provided by these forums, consider hiring someone]

Reply

You must log in to post.

About this Topic