WordPress.org

Ready to get started?Download WordPress

Forums

Comments Closed on All Posts Over 6 Days Old on TWO blogs (72 posts)

  1. AlisonMooreSmith
    Member
    Posted 3 years ago #

    Very strange. Two of my blogs (so far...) have suddenly closed all comments on all posts. One of the two blogs has two posts with open comments, the two posts published yesterday. The other blog hasn't been updated since Sep 17 and the same thing happened there.

    In addition to having comments on EVERY blog post (except the two listed above) deselected on EACH blog page, there are other weird issues. Three discussion setting that I have never used, never set, and certainly did not change recently were checked today on BOTH blogs.

    (1) Users must be registered and logged in to comment
    (2) An administrator must always approve the comment
    (3) Break comments into pages with...

    Strangely, neither of them had the "Automatically close comments on articles older than x days" -- even though that is what seems to have happened.

    Similar problems are documented here and here.

    Tried deactivating EVERY plugin - no change. Tried changing to default theme - no change.

    It seems I can change these manually -- although I don't know if they will eventually revert -- but I have hundreds of posts.

    Any ideas???

  2. AlisonMooreSmith
    Member
    Posted 3 years ago #

    I went through both blogs and made bulk changes -- page by page -- to reopen the comments the day I posted this.

    Today, all comments are closed again on BOTH blogs. The home improvement blog has been updated. The blog setup blog hasn't been touched since I posted. I haven't even been to the site since I corrected it and now it's comments are closed.

    Any ideas???? Please!

  3. AlisonMooreSmith
    Member
    Posted 3 years ago #

    I manually reopened every post yesterday. Closed automatically again today. On both sites. I haven't done anything to either one today.

    Does anyone have ideas about this?

  4. AlisonMooreSmith
    Member
    Posted 3 years ago #

    I think I have found a clue to this problem -- if anyone at WP cares.

    Last night I was looking at the back end of my easy blog setup blog. I don't recall what I was doing when I went to bed, but whatever it was, it triggered the login popup window that comes up to allow you to re-login without losing your data. When I got up this morning, the popup window was on the screen.

    THAT blog, again today, had all comments closed and all above settings changed.

    My custom home blog -- that I did not open and that did not have the popup login window -- is fine, with no changes.

  5. AlisonMooreSmith
    Member
    Posted 3 years ago #

    Apparently, that wasn't the issue. (Although that still would have been a serious bug.) This problem still occurs with both blogs whether or not they are open.

  6. AlisonMooreSmith
    Member
    Posted 3 years ago #

    I'm still hoping for some feedback...any feedback. This happens every single day.

  7. AlisonMooreSmith
    Member
    Posted 3 years ago #

    Today one of the blogs reverted once and the other twice. I did nothing to update the one that reverted twice except to re-open the comments and change the discussion settings back.

    Please, does anyone have input on this?

  8. AlisonMooreSmith
    Member
    Posted 3 years ago #

    I'm still really hoping ANYONE has info on this. This is ruining my blogs because I can't get any comments unless someone catches the blog when it's actually open. Please? Input?

  9. AlisonMooreSmith
    Member
    Posted 3 years ago #

    Deactivated ALL plugins, went to default theme, AND repaired database (nothing to repair, BTW), and the blog still closed all comments and change the settings a couple of hours later.

    Freak. I see strange incidents of this all over the web in small numbers. Anyone help?

  10. AlisonMooreSmith
    Member
    Posted 3 years ago #

    Happening 2–3 times per day now. Anyone?

  11. rjhayton
    Member
    Posted 3 years ago #

    Yea I'm having a similar problem. The silence is deafening....

  12. AlisonMooreSmith
    Member
    Posted 3 years ago #

    True that, rjhayton. Hoping to find more people with this problem so that we might warrant some attention.

  13. AlisonMooreSmith
    Member
    Posted 3 years ago #

    BTW, you can bulk edit your posts, but as far as I know you can only do it a page of posts at a time.

    Go to Posts>Posts

    Click the checkbox next to "Title."

    Select "Edit" under the "Bulk Actions" popup menu.

    Click "Apply."

    Select "Allow" under "Comments" and "Pings."

    Select "Update."

    Go to the next page and do it again. And again. And again. :(

  14. AlisonMooreSmith
    Member
    Posted 3 years ago #

    Found a clue to this problem -- albeit probably a small one.

    My blogs seem *relatively* stable -- as long as I leave most of the posts with closed comments. As soon as I take the time to open all the comments, they all revert again.

    To be clear, sometimes it happens when all comments aren't open, but doesn't seem to occur as often. Last night -- after about a week with one blog being stable -- I opened all it's comments. By morning they had all reverted to closed with changed discussion settings.

    Please, someone look into this. It's not a plugin or theme issue.

  15. rjhayton
    Member
    Posted 3 years ago #

    I haven't had the problem of it closing my comments again yet. I changed my settings and mass opened the comments on my posts. Then I disabled all plugins, and after about 12 hours or so I enabled Akismet, then later that day I enabled some of the other plugins. So far I haven't had any repeat issues.

  16. Drawer
    Member
    Posted 3 years ago #

    I disabled all plugins for only an hour or so, and then re-enabled most. Did bulk edit, still okay.

    I just realized I didn't reactivate feedburner or google analytics plugins, though! I don't think either are particularly useful to me - especially analytics. So I just reactivated only feedburner.

    I'll report back if that makes a difference.

    I think it can make a difference where you are when you turn the computer off - I don't shut down the pages, let Firefox do it. Sometimes the next day I have to log in again, but mostly not.

  17. rjhayton
    Member
    Posted 3 years ago #

  18. AlisonMooreSmith
    Member
    Posted 3 years ago #

    As I posted on the other thread:

    solidariti, I don't know what you mean by an incorrect slug. This bug has never occurred for me when I post a NEW post (by whatever name). It occurs when I'm offline and, sometimes, when I haven't updated a blog in weeks.

    I am not having issues with duplicate post slugs.

    rjhayton, you said that your were similar, but that would also be a hug bug to have SIMILAR post slugs cause all the comments to shut down. ????

  19. tcsoul
    Member
    Posted 3 years ago #

    I'm having this same problem, and I'm actually starting to toy with just using a different commenting system rather than mess with the WordPress bug. Facebook commenting may be a better route to go anyway...

  20. AlisonMooreSmith
    Member
    Posted 3 years ago #

    tcsoul, glad to hear from others with this problem! Hoping to get SOME kind of traction and resolution.

    Question: Does using another commenting system circumvent the bug? Or does the bug just extend through?

    Also -- if anyone reading knows -- if you switch to another commenting system can you switch back easily, bringing the comments with you? I actually like the simplicity of the WP commenting system, but this bug has made is anything BUT simple. :(

  21. esmi
    Forum Moderator
    Posted 3 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Ten theme to rule out any theme-specific problems?

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

  22. AlisonMooreSmith
    Member
    Posted 3 years ago #

    Hi esmi. As per above, I have deactivated all plugins (still happened) and switched to default theme (still happened). I also repaired the database (had nothing wrong). I have not reset the plugins folder. But I'll try that, too.

  23. AlisonMooreSmith
    Member
    Posted 3 years ago #

    Reset did nothing. All comments closed and settings changed again today.

    Is there a way to report a bug somewhere?

  24. AlisonMooreSmith
    Member
    Posted 3 years ago #

    BTW, I'm using version 3.0.1, not 2.9.2 as it says in the right sidebar.

  25. AlisonMooreSmith
    Member
    Posted 3 years ago #

    Now both blogs are back to shutting down comments and changing discussion settings at least daily, with no input from me.

    If anyone has input, I'm all ears. Don't know where else to turn...

  26. rjhayton
    Member
    Posted 3 years ago #

    Hey,

    Have you tried getting rid of any widgets you created with extra code in them, too?

  27. MissAmber09
    Member
    Posted 3 years ago #

    This has happened to me three times in the last month. I wake up in the morning to discover that the comments on all my blog posts are closed but I did not close them. Then, today, I woke up to find out that somehow my blog had set itself so you have to be logged in to wordpress to leave a comment.

    This is REALLY frustrating me, could we get some answers please!!

  28. rjhayton
    Member
    Posted 3 years ago #

    I started a new thread on this topic too: http://wordpress.org/support/topic/another-comments-problem-mabye-a-new-wp-30-bug?replies=8

    Not getting help there either. It happened twice for me separated by about 2 weeks. I didn't do anything to spark the change in settings either time.

  29. AlisonMooreSmith
    Member
    Posted 3 years ago #

    rjhayton, no, I haven't gotten rid of all my widgets. :/ I hate to go there. Ack. But worth a try, since NO ONE IS LISTENING!

  30. Drawer
    Member
    Posted 3 years ago #

    Hasn't happened since I last wrote a month ago, but since there's trouble...I'm B-A-A-C-K!

    Since I rarely get comments, I didn't notice they were closed until I saw Akismet was finding no spam. Even they can't get in. I suspect it's spam that is triggering this somehow.

    Wait - I just checked and Alison is right:
    (1) Users must be registered and logged in to comment
    (2) An administrator must always approve the comment
    were also checked, and I never ever check them. How could spam get in our admin?

    It tells me I have 2.8.4. It never told me this before - in Dashboard box. (yeah, I gotta upgrade.)

    Not happening in my other blogs. Will read other threads on this.

Topic Closed

This topic has been closed to new replies.

About this Topic