WordPress.org

Ready to get started?Download WordPress

Forums

Comments Closed on All Posts Over 6 Days Old on TWO blogs (72 posts)

  1. AlisonMooreSmith
    Member
    Posted 3 years ago #

    Mine are kind of stable right now AS LONG AS I DON'T OPEN COMMENTS. Yea, lousy solution.

    If I go into either blog and manually open up all the comments, it trips the bug to close them all, usually within a few hours, always within about a day. Really annoying and no one seems to notice.

  2. Jowy
    Member
    Posted 3 years ago #

    This is happening to me too... horrible bug. It happens once every 2 weeks to me. Can you list your plugins so we can compare?

  3. AlisonMooreSmith
    Member
    Posted 3 years ago #

    Jowsy, what version are you using. Since I upgraded to 3.0.4 I haven't seen it. I opened all the comments a few days ago and, so far, they are stable.

    If you haven't upgraded, try doing so. Maybe they fixed it?

    I agree, it was terribly frustrating!

  4. Jowy
    Member
    Posted 3 years ago #

    I was on 3.0.4, now on 3.0.5. I hope it is fixed!

  5. rjhayton
    Member
    Posted 3 years ago #

    It's still happening to me on 3.0.5. Arggh... But about every 2 weeks not every day.

    I don't know how to test this. Once the settings get flipped again so people have to login and no comments are allowed globally and comments are disallowed on every individual post. My question is, do I just deactivate plugins and change the theme right then to see if something I change fixes it? Previously I've restored all the settings manually then changed themes and erased plugins.

    It's dangerous to leave Akismet off and keep comments opened for 2 weeks waiting for the bug to reappear or not.

    I really wish they would step in and help diagnose this. It seems to be a widespread bug.

  6. Jowy
    Member
    Posted 3 years ago #

    Ditto. Still happening for me too. Just to clarify the issue I am having: I uncheck the "Users must be registered and logged in to comment" setting, but it keeps reverting back to checked. It seems to happen randomly. Sometimes it will be ok for a few weeks and revert, sometimes it will take only a day or two to revert.

    Here is a list of my active plugins:

    -Akismet
    -Audio player
    -Conditional CAPTCHA for WordPress
    -Dashboard Post-it
    -fbLikeButton
    -Google Analytics for WordPress
    -NextGEN Gallery
    -Photo Sidebar Widget
    -Podcasting Plugin by TSG
    -Share a Draft
    -Sociable
    -Tumblrize
    -WPtouch

    My theme is "Green Light" by Template Lite.

    Please post yours so we can see if there is anything similar that raises a flag.

  7. rjhayton
    Member
    Posted 3 years ago #

    I have tried with and without various plugins to no avail.

    Akismet
    Datafeedr Random Ads V2
    Efficient Related Posts
    Fast Secure Contact Form
    FD Feedburner Plugin
    Mingle Forum
    Subscribe to Comments Reloaded
    WordPress.com Stats
    WPtouch

    I'm pretty sure I scaled down more than this and it still happened, but I don't remember.

    What I'm going to do is remove WPtouch to see if that helps. Although I have that with another site which this problem doesn't happen on.

    My theme is Staypressed theme by Themocracy.

    I will also try to rebuild my Plugins as noted here: http://codex.wordpress.org/FAQ_Troubleshooting#How_to_deactivate_all_plugins_when_not_able_to_access_the_administrative_menus.3F

    Don't know what else to do if we continue to get no help on this.

  8. AlisonMooreSmith
    Member
    Posted 3 years ago #

    I removed all the plugins from one site, and the nonessentials from another. Did not solve the problem. I reverted to the default theme on one to test. Did not solve the problem.

    I do not think this has anything to do with plugins or theme. I think it's a WordPress bug. Still happened with stripped down versions.

    And, yes, they REALLY need to address this, but it's like yelling into a vacuum.

  9. rjhayton
    Member
    Posted 3 years ago #

    Alison,

    Has it happened since you upgraded to the most recent WP version? In one post you indicated that it had helped....

  10. AlisonMooreSmith
    Member
    Posted 3 years ago #

    It hasn't happened to ME since I upgraded to 3.0.4. Don't know if that's luck or what, but obviously others are still having the problem.

    This bug can really blow the traffic on your blog and it hurt mine a lot. So I'm sticking in and hoping to help push this issue into sight.

  11. tico007
    Member
    Posted 3 years ago #

    I just figured my problem(s) out. Would appear there's a bug in WP's upgrade script....

    Multiple blogs migrating from 2.8 to 3.0.5. Everything seemed ok, Days later I became curious why there were no comments posted on one of my larger blogs with thousands of posts. I noticed the comment form was missing. First assumptions incompatible plugins or theme. Wasn't that. Default theme says "comments closed". Next on to discussion settings on the admin panel, found this thread. Its been a long time since initial setup, all looked normal except for all blogs have "An administrator must always approve the comment" unchecked. I thought that was wrong, still went to moderation either way.

    Then I realized that all the individual posts "Allow Comments" was unchecked!!!, and according to wordpress, SOL flipping a switch...

    soo...experimented with this plugin (not updated but works with 3.0.5) saved me big time!!!!!

    http://wordpress.org/extend/plugins/extended-comment-options/

    Poof, thousands of posts open for business with one click. Cool features. Tell @maerk not to give up on this plugin!!

  12. rjhayton
    Member
    Posted 3 years ago #

    Thanks for the tip, I'll try that plugin to make it easier to fix this issue every couple weeks when it happens.....

  13. rjhayton
    Member
    Posted 3 years ago #

    With the "auto" option on this plugin, it might be a work around permanently (assuming it doesn't mess anything else up)....

  14. tico007
    Member
    Posted 3 years ago #

    I just deactivated the plugin as a test, the global setting to allow comments on individual posts remain, so the plugin just adds features to the core WP. Keep this plugin !

    More clarification on the "Bug" comment above. When they say "disable all plugins and themes prior to upgrade", do it. This blog failed because of the way 3.0.5 used Akismet to distribute some WP bug fixes. When it failed, the database upgrade didn't complete that is required from 2.X to 3.X. I had to perform manually. So that makes a WP bug less clear.

  15. AlisonMooreSmith
    Member
    Posted 3 years ago #

    tico, I'm not sure I'm following you on the last two comments.

    To be clear, this never happened when I upgraded. It happened — sometimes daily — even on a blog that hadn't even had the dashboard opened. Comments open at night. Go to bed. Get up. All comments closed.

  16. tico007
    Member
    Posted 3 years ago #

    AlisonMooreSmith, your issue sounds like a scheduled process or a cron somewhere. Your ISP should provide you the logs. My problem was static. I think the Extended Comment Options plugin will help with your issue for now.

  17. AlisonMooreSmith
    Member
    Posted 3 years ago #

    tico, I'm not sure what you mean by "a scheduled process or a cron somewhere." My issue was similar to what many others experienced.

    I don't have the issue now, but am hoping to help bring this to the forefront for those still experiencing it.

  18. fusse
    Member
    Posted 3 years ago #

    I'm facing the same problem.

    I had a thought that maybe something got messed up in an upgrade process. So I'm waiting for 3.1 and when that comes out, I will try to upgrade in such way that certainly fixes everything.

    Also I thought that this could be somehow tied to "a scheduled process or a cron somewhere." but I can't track that down.

    My host is ipower

  19. rjhayton
    Member
    Posted 3 years ago #

    Actually, I think the plugin above that tico007 mentions is the answer to this problem. I installed it and turned all my comments on at one touch. Plus there's an auto box to automatically keep it that way, so I think that will overrule any bug out there for now....

  20. AlisonMooreSmith
    Member
    Posted 3 years ago #

    OK. It just happened to me again. But on a DIFFERENT blog. And this time, I just about "saw" it happen.

    I was on the blog (not in the admin area), replying to a comment. I submitted the comment. It kind of cranked for a few minutes, then finally posted the comment, but when the page refreshed ALL the blog comments were closed. Ack!

    Here's the blog:

    Mormon Momma

    Fortunately rjayton had posted (in a similar thead) about the Extended Comment Options plugin (thank you thank you), so I installed that and opened all comments. Then I went to the SAME post, replied again to another comment, submitted. NO PROBLEMS.

    WORDPRESS, THERE IS A PROBLEM!

  21. tico007
    Member
    Posted 3 years ago #

    Checking page source on "Mormon Momma" I see a plugin called "commentluv". Went over to creators website, see a reference to an issue on the "commentluv" network regarding auto-closing and spam. If this plugin is running on all your blogs, disable one and see if the problem goes away.

  22. AlisonMooreSmith
    Member
    Posted 3 years ago #

    Mormon Momma didn't used to have this problem, but I disabled ALL plugins on ALL the other blogs and the bug still occurred.

    If you read the first comment in this thread you'll see that.

    Right now I'm having this problem ONLY on MormonMomma, even though I have CommentLuv running on two other blogs as well. :/

    Note that the plugin "fix" doesn't change the "Users must be registered and logged in to comment," you have to manually fix that as well.

  23. AlisonMooreSmith
    Member
    Posted 3 years ago #

    tico007, I just checked the link you sent. Not sure how this relates. This is the CommenLuv creator, but he's just saying that he created a DIFFERENT plugin to auto close old posts on blogs that are on HIS network. (You can have a CommentLuv blog on his server if you are a registered CommentLuv user.)

    This has nothing to do with any of my blogs -- or most blogs. Unless I misunderstood you?

  24. tico007
    Member
    Posted 3 years ago #

    I thought that because your having comment problems, and have a comment plug-in deployed it could be causing issues. If this problem is widespread and not unique to your configuration(s), there will be a flood of people replying to this who can help you better than me. If, as in my case, the comments were close during an upgrade or some other change, use my suggestion above (Extended Comment Options), and you should have no further issues.

  25. AlisonMooreSmith
    Member
    Posted 3 years ago #

    As I said, I have had the issues occur with plugins and with no plugins at all (even Akismet disabled). I've had it with the Thesis theme and with the default theme. I've had it occur (once) when I was posting a comment from the admin area, but more often than not when there was no site activity other than visitors reading the site.

    The plugin you refer to reverts the erroneous settings, but does not keep them from occurring again.

  26. Alison, at this point, open a trac ticket with your info. It's not a reliably reproducible bug, in that it's rare and wildly uncommon, so you will have to be willing to work with the devs, if they can sort it out.

  27. Drawer
    Member
    Posted 3 years ago #

    Just coming back to say IT'S B-A-A-A-CK.

    Only took a few minutes to change permissions, so admin doesn't have to approve, don't have to register, etc, and turn comments all back on, thx to Alison's suggestion a while back, but still very annoying. This has happened on 2 out of 4 blogs. It's probably been a couple of months since the last time, so Ipstenu is right, it's irregular. I don't know if it's uncommon - lots of people don't know how to complain.

    Interestingly, Ipower was down for an hour last week, and also 2 days ago - I'm wondering if that had something to do with this.

    I do have older version of WP on 3 blogs. And fusse, I STRONGLY recommend that you NOT upgrade to 3.1 at all - read all the problems. They need a new version before people should upgrade.

  28. hamlet9000
    Member
    Posted 3 years ago #

    This has been happening about once a week at http://www.thealexandrian.net. And it only started happening when I upgraded WordPress to the latest version.

    It's clearly a problem with WordPress.

  29. Drawer
    Member
    Posted 3 years ago #

    Happened again today, but only on 1 blog - so it took 2 weeks. It can't be a plug-in, to change internal admin pages like Discussion! (changes permission to post w/out approval, and says admin must approve - neither of which I have EVER checked.)

    This time it happened soon after someone left a comment. I changed permissions to fix, and also edited ALL my posts again to allow comments again. Then tried to answer his comment. I got some comments.php errors - blank pages, had to keep resending and refreshing.

    I don't understand php at all, so I don't know if that's it, but maybe? It's 8.4. NO WAY I'm going to upgrade to 3.1 until they fix it for Windows users. Here's the site: http://thecartoons.net/

  30. hamlet9000
    Member
    Posted 3 years ago #

    Ping.

    Happened again. At this point I wish there was a way I could reverse time and go back to the old version of WordPress that didn't periodically sabotage my website.

Topic Closed

This topic has been closed to new replies.

About this Topic