WordPress.org

Ready to get started?Download WordPress

Forums

Comments box causing Google News problems (6 posts)

  1. pain_in_the_arras
    Member
    Posted 4 years ago #

    Hi there,

    I've recently started using Arras as the theme for my site and it's caused a couple of Google News indexing errors - sometimes the Title of the article isnt indexed, but a random sentence is - meaning that the random sentence becomes the title in google news, which is obviously not good.

    That's not really the problem here though (I read around and decided to un-hyperlink the titles of articles which should help)

    But what is a bigger problem is that Google is randomly re-indexing articles at a later date, using the address of the article (eg. http://www.mysitename.com/archives/etc/article_title_here this is how Google indexes them first time) but adding on /comment-page-1 for the second time it indexes, so, http://www.mysitename.com/archives/etc/article_title_here/comment-page-1 is how it would be indexed second time.

    The amount of time between this second indexing is pretty random, sometimes a few hours later, sometimes a few days...

    Does anyone have any suggestions on how to fix this.....
    Examples can be found here and here

  2. s_ha_dum
    Member
    Posted 4 years ago #

    Look into robots.txt.

  3. pain_in_the_arras
    Member
    Posted 4 years ago #

    Thanks for the response; I can't seem to find a robots.txt in my files - any ideas where it lives by default (soz if stupid question!), and how to disallow JUST the comments version of the page from being indexed as i'd obv still want the main article to show up!

    Cheers...

  4. alism
    Member
    Posted 4 years ago #

    The robots.txt doesn't exist by default. It's a file that you create yourself to exclude indexing of certain files by search engines. It would live in your root directory.

    It's quite a powerful little file, and you can end up blocking your whole site from being crawled if you're not careful.

    Have a read of some of the links from apljdi's google query, but you'll probably want to use something along the lines of:

    User-agent: *
    Disallow: /*/*/comment-page-*

    I think most of the major engines support wildcards these days.

    (that's just off the top of my head, so hopefully someone will double check that code above! :-)

  5. pain_in_the_arras
    Member
    Posted 4 years ago #

    Can anyone verify that that is the correct code?

    Thanks for the response alism...

  6. pain_in_the_arras
    Member
    Posted 4 years ago #

    Ok, well instead of playing around with a robots.txt I unchecked the box that instructs wordpress to break comments into pages (set to 50 per page by default i think)...which seems to have done the trick combined with removing the hyperlinked titles.. will let you know if the problem resurfaces...cheers guys

Topic Closed

This topic has been closed to new replies.

About this Topic