WordPress.org

Ready to get started?Download WordPress

Forums

Comments aren't listed in the admin panel wordpress 2.5 (24 posts)

  1. knightcrawler2
    Member
    Posted 6 years ago #

    Installed a fresh copy of WordPress 2.5 then import a database file and everything seems fine until I noticed none of the comments are not listed in the admin panel comment list.

    Anybody have an solution or answer?

  2. jmfolcik
    Member
    Posted 6 years ago #

    I have the same problem, the commends show up on the actual blog, and they show up under the manage post page, but comments says: No results found. for "show all comments"

  3. jmfolcik
    Member
    Posted 6 years ago #

    Is anyone else having this problem? I have a feeling it is from people who started out with 2.3.3 or around there. I even tried export, deleted a post that had a comment, then import (so it would actually import something with the one missing) and that didn't fix the problem. Is there some sql command I can do to fix a table or something?

  4. knightcrawler2
    Member
    Posted 6 years ago #

    I think I'm going to upload 2.5 again in a different folder and try again

  5. jmfolcik
    Member
    Posted 6 years ago #

    I fixed it! I went and read the error_log file from apache and it told me exactly what it failed to pull from sql. It told me "Key 'comment_date_gmt' doesn't exist in table" so I went to the table it talked about and created that as a key. I tried that same thing before but I had the wrong table, I did it to an old table that I'm not using anymore since I have multiple instances now of wordpress.

  6. Amit Gupta
    Member
    Posted 6 years ago #

    @jmfolcik:

    I have a feeling it is from people who started out with 2.3.3 or around there.

    I upgraded a v2.3.3 blog of mine 3-4 days back, upgraded it in 2 minutes(including backup etc) using Fantastico & it went ahead without any problems & is still running pretty cool :)

  7. jmfolcik
    Member
    Posted 6 years ago #

    Did you begin at 2.3.3 or did you upgrade from an older version to 2.3.3 previously before going to 2.5? I started at 2.3.3, and was missing the key in my database, as it seems others do as well.

  8. Dangerdom
    Member
    Posted 6 years ago #

    This sounds like exactly what I need, unfortunately I am not that great at understanding what you are talking about, I am a noob when it comes to the real in depth stuff. Can you describe it a little bit more in depth.

    Is it a file that I can edit?

    Do I have to be using Apache in order to achieve the desired results?

    Any and all help is appreciated.

  9. jmfolcik
    Member
    Posted 6 years ago #

    This is within your database, so if you are using microsoft sql or mysql, a sql admin tool is used to fix it. Someone can probably fix it remotely for you but I'm not at that skill level, I still need the GUI to do anything.

  10. eexlebots
    Member
    Posted 6 years ago #

    I had this same exact problem and jmfolcik's solutions worked for me; from phpmyadmin I selected the database, then selected the wp_comments table and viewed it in "Structure" mode.

    Oncer there I selected the "comments_date_gmt" field and checked the "index" option. Once I did that and it reported a success I checked my WordPress site and comments were back with no errors!

    I did have to create an admin accoutn with higher privileges to make the change in the database, for some odd reason; but I didn't have to change my site's MYSQL login stuff in the wp-config file, which was good :)

    Thanks a million jmfolcik!

  11. lugarza
    Member
    Posted 6 years ago #

    phpmyadmin is blank when i try to use it. :/

    I hope this gets patched in the next version...

  12. Dangerdom
    Member
    Posted 6 years ago #

    Whoo! Thanks eexlebots! Worked perfectly for me.

    Lugarza: I had the same issue at first, phpMyAdmin shows a blank screen in firefox and safari. It worked for me in Opera, Camino, and IE.

  13. steve_magoo
    Member
    Posted 6 years ago #

    Thank you eexlbots! Was getting very frustrated....

  14. aussiepunter
    Member
    Posted 6 years ago #

    Thanks jmfolcik and eexlbots! Like others that was giving me a huge head ache.

  15. bigsquaredot
    Member
    Posted 6 years ago #

    This is an excellent thread. Thanks for the help gang. For those who have a blank screen when trying to use phpmyadmin, turn off all javascript in your browser and it should display.

  16. Valerie123
    Member
    Posted 6 years ago #

    Thanks eexlebots for the step by step tutorial, I followed it and it works great! I'm so excited that it's working again.

    Lugarza- Are you looking at PHPMYADMIN in Firefox? If so Try IE, it's blank for me in Firefox, but works in IE. Perhaps that will work?

  17. ismyrnow
    Member
    Posted 6 years ago #

    The comment posted by eexlebots worked brilliantly! You're a lifesaver!

  18. UncleZeiv
    Member
    Posted 6 years ago #

    works for me as well

  19. laroca
    Member
    Posted 6 years ago #

    eexlebots,

    How do you create another "admin accoutn with higher privileges"?

    Thanks for all your help!

  20. lugarza
    Member
    Posted 5 years ago #

    Finally I got this sorted out. Thanks everyone for the help.

  21. lugarza
    Member
    Posted 5 years ago #

    Finally I got this sorted out. Thanks everyone for the help.

  22. iDope
    Member
    Posted 5 years ago #

    Works perfectly, thanks!

  23. teambiff
    Member
    Posted 5 years ago #

    eexlebots' instructions should be highlighted as an answer in the Troubleshooting FAQ and the fix (or at least check) should be incorported in future WP updates.

    I diligently update my WP when a new version is released and that problem has existed almost for a full year until now - thank you!
    ~Biff.

  24. webmaestro
    Member
    Posted 5 years ago #

    Yes... eexlebots instructions for fixing this in phpmyadmin, are good. Unfortunately, if you don't have access to phpmyadmin, you'll need the SQL statement it runs with such ease. I had a similar problem, but with WordPressMU (and no access to phpmyadmin). I included my fix on the WordPressMU forums:

    http://mu.wordpress.org/forums/topic.php?id=9259#post-55458

    If you're lazy (or you don't feel like following that link... ;-), here's the meat:

    The fix is to CREATE an INDEX on the 'comment_gmt' column in the 'wp_comments' table ('wp_XXX_comments' in the case of WordPressMU--follow the above link for more info).

    IMPORTANT: MAKE A BACKUP OF YOUR DATABASE FIRST

    CREATE INDEX comment_date_gmt_idx
      USING BTREE
      ON wpmu.wp_comments(comment_date_gmt DESC);

    Good luck!

    Web Maestro Clay

  25. bdayne
    Member
    Posted 5 years ago #

    Sadly, eexlebots instructions did not work for me, and my comments are now even more wonky than they were before I ran the fix. I started with a clean install of 2.6, and imported two databases into one blog. The comments were there after the imports, but the numbers in the little comment balloons under Manage were all reading zero. Also, on single post view the comments were there, but above them it read "No comments."

    After running eexlebots phpMyAdmin fix, the comment numbers returned for the the latest posts, across both databases, but the comment numbers on earlier posts are all still reading zero.

    And now, as if this weren't enough to deal with, on the main dashboard page, the Recent Comments section is showing comments from three years ago, and not the most recent ones, which had until today's db fix been showing up just fine.

    I noticed 2.6.1 is available, and am wondering if anyone knows if this bug (if that's what it is) has been sorted? I was going to wait until the next major release to upgrade, as my plugins are all working together nicely. But I'll do it now, if it will fix this issue.

    Baring that, does anyone have ANY ideas for how to proceed next?

Topic Closed

This topic has been closed to new replies.

About this Topic