WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
[resolved] Comments are showing when using Event Submission Form as Admin (10 posts)

  1. zenmaster2013
    Member
    Posted 1 year ago #

    Hi there

    With comments disabled in the Pages -> Event Pages -> Enable Comments? = NO

    When logged in as Admin - and I create a new event via. the Event Submission Form, the comments are showing on the Event page. This event is published automatically as I am Admin

    If I am not logged in, I can still add a new event as I have enabled: Allow anonymous event submissions? = YES

    This puts the event as pending... so I log in as admin and publish the event... No comments are showing.. so this works...

    I would like to add an event as Admin on the public submission form but without the comments showing..... Is there a workaround?

    http://wordpress.org/extend/plugins/events-manager/

  2. agelonwl
    Member
    Posted 1 year ago #

    hi,

    just to be clear, comments are showing up on event submission forms and not on single events page, it this correct? if yes, then this could be a theme issue you might want to disable comments on your wp page - event submission form or use other wp plugins e.g. http://wordpress.org/extend/plugins/disable-comments/

  3. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 year ago #

    that first setting you mentioned is for event themselves, not actual WP pages.

    e.g. go the submission page itself, in your wp admin bar on top click 'edit page' and then disable comments directly from there.

  4. zenmaster2013
    Member
    Posted 1 year ago #

    No, the comments are showing on "The Event Page"

    To replicate:

    1) Sign in wordpress as admin
    2) Create an event via. a front facing event submission form
    3) The event is automatically published (I guess because Admin did the form)
    4) Visit the event page

    Comments are showing..... Even if: Pages -> Event Pages -> Enable Comments? = NO

    Now....

    1) Sign out as Admin
    2) Create an event via. a front facing event submission form
    3) The event is not published yet, so sign in as admin and publish the event
    4) Visit the event page

    Comments are NOT showing... this is working as expected?

  5. caimin_nwl
    NetWebLogic Support
    Posted 1 year ago #

    What happens if you add the event from within WP admin? Do you get the same behaviour?

  6. zenmaster2013
    Member
    Posted 1 year ago #

    Hi caimin_nwl

    If I add the event directly in the WP Admin, it works just fine.. :)

    This of course is one way to do it, but would be useful to do it directly from the front-end submission form.

  7. zenmaster2013
    Member
    Posted 1 year ago #

    I believe it to be a bug, not critical, but thought I would mention it.

    If:

    Pages -> Event Pages -> Enable Comments? = NO

    Then comments should be disabled in Event page regardless of how the event is created and published.

  8. agelonwl
    Member
    Posted 1 year ago #

    you need to edit the events and unchecked 'Allow comments' to disable comments (if you already allow the comments upon creation)

  9. zenmaster2013
    Member
    Posted 1 year ago #

    (if you already allow the comments upon creation)

    I dont allow... thats the problem...

  10. agelonwl
    Member
    Posted 1 year ago #

    hmm, works for me; just to narrow down the problem can you try to temporarily:

    - deactivating all other plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic