WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Comments are closed, I can't open them - and there are NO universal settings (38 posts)

  1. baia
    Member
    Posted 3 years ago #

    @James : I followed all what you said. First I desactivated all plugins, then I switched to the default theme, then I repaired the tables in PhpMyAdmin, nothing !

    Some of my posts have comments working, others have "comments are closed" for no apparent reasons. And the post slugs look normal :/

  2. baia
    Member
    Posted 3 years ago #

    Ok the solution was :

    edit a pre-existing post - scroll to bottom of page and see if comments are allowed

  3. patrickq
    Member
    Posted 3 years ago #

    A Hidden Solution That Worked Easily :-)

    I bolded the above in the hope that it will be the right solution for many of you with this problem.

    I had done all of the changes in Settings/Discussion in the WordPress Dashboard, to make comments open. I had de-activated all plugins (only 2 anyway). I had tried different themes. I had checked lots of other forums on this. Still I got the dreaded 'Comments Closed' for all of my posts. I had thought there was going to be no solution short of getting into techie php stuff, which I have no idea about ... then the God's smiled and dispensed their infinite wisdom, to enable me to see the light :-)

    So, I decided to not only read the instructions (which first involved finding them), but also managed to actually make sense of them. I hope this works for others who can't figure out what is going on.

    First, I'll assume that you are allowing comments, which can be set on the page that is your website URL ending with: /wp-admin/options-discussion.php

    Then, in the Dashboard click Posts, then click the Edit button for a post that you wish to adjust to allow comments.

    On the top right of that post page you will see 'Screen Options' click this and it will display all kinds of hidden options. Select the Discussion and Comments boxes, along with any others you wish to see displayed. Now close 'Screen Options'.

    You should now see Discussion and Comments options shown at the bottom of the page, below your post editing box. So, just select the 'allow comments' box under Discussions and you're away, Yippee!

    I think this may well then set as the default for all posts, so check.

    So, comments are now open on my UniversalRiches blog all I have to do is get writing articles. I find it quite interesting, I've just noticed that this topic title ends with the words "... there are NO universal settings" which has to be relevant to my blog :-)

    Patrick

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    A Hidden Solution That Worked Easily

    This "solution" has been posted quite frequently since 3.1.1 was released... :-)

  5. patrickq
    Member
    Posted 3 years ago #

    Wish it had been on this thread, unless I inadvertently passed it by, would have saved me plenty of time :-)

    So, maybe it came about when I carelessly decided to throw caution to the wind and upgraded to the latest version!

  6. AlisonMooreSmith
    Member
    Posted 3 years ago #

    I'm not really sure what you're presenting here, patrickq. While the hidden options has been around for a while, this doesn't resolve the problem if I read your post correctly.

    (1) There is no "discussion" checkbox (you said, "Select the Discussion and Comments boxes, along with any others you wish to see displayed. Now close 'Screen Options') in 3.1.1 or in 3.0.4 (the two I checked).

    (2) In the example above you are editing a PARTICULAR post, not some universal post setting. ("click the Edit button for a post that you wish to adjust to allow comments.")

    (3) The "universal setting" is set here /wp-admin/options-discussion.php, but it only applies to new posts. It doesn't go back and reset OLD ones. THAT is the problem. If all old posts have reset to closed, changing them all (either individually or in batches) is a nightmare if you have even a few dozen posts, if you have to do it regularly.

    The only reasonably easy fix I've seen -- after WP has crapped out -- is to use the Extended Comment Options plugin to open all comments at once. A feature WP should have built in.

  7. patrickq
    Member
    Posted 3 years ago #

    Alison, all the answers I couldn't find are now appearing, the plugin looks like a good solution.

    Maybe I didn't explain things well enough in my post, I was trying to balance being overly descriptive with being too brief. Bottom line is that I had a problem with comments not being allowed and tried most of the suggestions I found earlier in this thread to no avail. When I made the adjustment I outlined it resolved things for me.

    I just updated to WP 3.1.1 today and this is the version I was referring to.

    There is a Discussion box option (at least for me) but only when you go to the edit page for a particular post, it doesn't show on the page that shows a list of all your posts. Hope I've worded this unambiguously, as I'm not particularly clued up on using WordPress and the correct terminology - the use of pages/posts leaves room for misinterpretation.

    You are correct in saying that my suggestion is for editing a particular post, but this is a step forward when no matter what you do in the overall settings you still cannot change to 'comments allowed'. It does mean that all posts can be set as you wish, now that the option is presented beneath each post, even if it is tedious.

    However, this is why I said "I think this may well then set as the default for all posts, so check" as I think that doing this for the one comment changed it to the default for them all, but I can't be sure as I wasn't paying detailed attention at that point, it is just that I noticed some posts no longer needed adjusting when I went to do so. At that point I wasn't thinking of making a post about this and didn't take notes, so it is up to someone else to see what happens and let us know.

    I maybe have one blog with a few posts that I can test this on when I have a moment, but will have to look at it and get back with the info.

    Patrick

  8. AlisonMooreSmith
    Member
    Posted 3 years ago #

    I see, thanks for the clarification.

Topic Closed

This topic has been closed to new replies.

About this Topic