WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Comment permissions (11 posts)

  1. brandy20
    Member
    Posted 3 years ago #

    Hello, I run a brand new blog, at the moment no comments on my posts, but when I try to access the comments link on the dashboard I have the message: You do not have sufficient permissions to access this page.

    Anybody can help?

  2. It sounds like your account may have lost admin privileges for some reason.

    Access your database via phpMyAdmin (most hosting providers offer this in their control panel), go to the wp_users table and find the row for your user_login . Note the ID of this row. Now, go to the wp_usermeta table and find the wp_capabilities row for your user_id . Set the value of this row to a:1:{s:13:"administrator";b:1;}

  3. brandy20
    Member
    Posted 3 years ago #

    Thank you James, it's the only link with the problem , the rest works fine. I'll try that.

    Luca

  4. brandy20
    Member
    Posted 3 years ago #

    James, I went to phpMyAdmin and took a look at wp_paqa2e_capabilities and this is what I found:

    a:1:{s:13:"administrator";s:1:"1";}

    I didn't touch anything since I'm new to this stuff.

    Tks, Luca

  5. That should be okay, but it wouldn't hurt to change it to a:1:{s:13:"administrator";b:1;} just to be sure. You can always change it back if it blows up even further. :)

  6. brandy20
    Member
    Posted 3 years ago #

    Thank you, now I have a big issue: I accidentally change the password to access the phpMyAdmin and now when I try to connect to the dashboard I get

    Error establishing a database connection

    How can I fix that?

    Tks again, Luca

  7. brandy20
    Member
    Posted 3 years ago #

    Problem fixed through wp-config.php file in my wordpress directory

  8. brandy20
    Member
    Posted 3 years ago #

    James,even with your changes I've got the same problem, but only for comments

  9. Well, I suppose it could be a plugin issue.

    Try deactivating all plugins. If that resolves the issue, reactivate each one individually until you find the cause.

  10. brandy20
    Member
    Posted 3 years ago #

    The guilty was finally found. It was the Intense Debate plugin. Now everything works fine. Thank you for your precious help James!

    Luca

  11. You're welcome!

Topic Closed

This topic has been closed to new replies.

About this Topic