WordPress.org

Ready to get started?Download WordPress

Forums

comment-page-1 issue with pages and articles (9 posts)

  1. charles.wilson
    Member
    Posted 2 years ago #

    I have noticed webmaster tools have picked duplicate pages with comment-page-1 issue. I have resolved this issues with my articles but the /comment-page-1 still appears at the end of my pages with wordpress http://www.eshop600.co.uk/john-lewis.html/comment-page-1/ , how do i remove the /comment-page-1/ please.

    I have already unceheck the box "Break cooments in to pages with" which has sorted out this problem for my articles, now i am getting this issue /comment-page-1/ at ehe end of my page urls http://www.eshop600.co.uk/john-lewis.html/comment-page-1/ , please can someone tell me how to fix this problem.

  2. charles.wilson
    Member
    Posted 2 years ago #

    There seems to be a technical error when you accept comments. If you have articles that links to any internal pages and you approve a comment on the article page, it causes the pages that are linked to, to have comment-page-1 created. This is because the pages have over 50 links to them so wordpress seems to create the comment-page-1 to break them up as pages. The problem is that you can stop this happeneing to articles but the only way I can see this stopping for pages is to delete all the comments.

    Has anyone else found this out.

  3. Go into /wp-admin/options-discussion.php

    Where it says 'Break comments into pages with ....', uncheck that box. That shuold stop it.

  4. charles.wilson
    Member
    Posted 2 years ago #

    I have done that, and yes it stops it for posts but not for pages

  5. charles.wilson
    Member
    Posted 2 years ago #

    This is a page http://www.eshop600.co.uk/john-lewis.html/comment-page-1/ not a post, how do i stop it for pages

  6. Notice how the page renders? It's okay :) It's the same as for http://www.eshop600.co.uk/john-lewis.html, WP parses it correctly for you.

    You can turn off comments for the page itself if you want to but the placeholder code still exists.

  7. charles.wilson
    Member
    Posted 2 years ago #

    The trouble is that the articles link have links within them that link to pages and this is why I am getting http://www.eshop600.co.uk/john-lewis.html/comment-page-1/ .

    The only way i can see how to correct his is to remove all the comments that are approved unless you have another idea.

  8. charles.wilson
    Member
    Posted 2 years ago #

    How do you switch off comments completely

  9. Please stop double posting, you keep tripping the spam filter ;)

    On Edit Page, click Screen Options and ensure that the Discussion box is checked. If so, you'll see a 'discussions' box on the edit page, and you can uncheck comments.

    The trouble is that the articles link have links within them that link to pages ....

    If you've LINKED to that page, you need to stop. Nothing within WP defaults to doing that, though.

Topic Closed

This topic has been closed to new replies.

About this Topic