WordPress.org

Ready to get started?Download WordPress

Forums

Comment Moderation bug? (16 posts)

  1. gregorsmith
    Member
    Posted 9 years ago #

    Sorry if this has been asked before, I trie to look for a similar problem with no luck, so I dunno...

    I'm currently running 1.5b1 2005-01-21 and I've noticed a distinct lack of spam comments, until I noticed the wp-comments table in the database, it's completely bloated with comments marked as spam, but not appearing in the awaiting moderation queue

    a recent example

    INSERT INTO wp_comments VALUES (4892, 13, 'online poker', 'absinth581@mail.ru', 'http://www.example.com/', '69.148.200.14', '2005-02-03 12:38:17', '2005-02-03 17:38:17', 'Please visit some information in the field of 'http://www.example.com/' online poker\r\n...', 0, 'spam', 0, 'Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; .NET CLR 1.0.3705)', '', 0);

    is this a known error? should I enter it in mosquito? should I upgrade to a newer build?

  2. Upgrade to a newer build first (it's always a good idea anyways, but make a backup first).

  3. gregorsmith
    Member
    Posted 9 years ago #

    Well, a little update to this problem...

    I installed the lastest nightly at the time (02-04-05) fresh and imported evertything bar the options table, I only edited the date format and post display in th option (there by leaving it with default moderation or spam control on). Soon enought I got the usual backlog of emails saying that comments need moderated, so I turned the option marked "Comment author must have a previously approved comment" off and pasted in the comment spam words list from the codex and once again nothing is coming up as needing moderted and again the comments table is becoming more and more full with comments that have a 'spam' variable in it.

    So I can only surmise that the comments spam words list is acting as a blacklist but not deleting the comments or WordPress is doing something by it's own accord that I've not asked it to do

  4. So they're still not appearing in the moderation que? And, are you sure that the words in the codex list apply to the words in your spam comments? For example, most of my spam is poker and casino-related. While the codex spam words list has "casino", it lacks to work "poker" by itself. I had to add the word "poker" in order for the blacklist to catch the poker comments. If you'd like to see my blacklist, it's here (but be warned, this subject matter is not suitable for children, or most adults for that matter): http://www.macmanx.com/wordpress/bad.txt

  5. gregorsmith
    Member
    Posted 9 years ago #

    The words apply, just the comments arent being markd for moderation, nor are they being published... they're just in the comments table in the database

    most odd

  6. hugo
    Member
    Posted 9 years ago #

    Comments that are recognized as spam by WordPress get the "spam" approved value. Those won't show up in the moderation queue. There are several additional rules that make out comments as spam in WordPress - for example HTML numerical entities in the standard ASCII range. So spam showing up in the table but not the queue is perfectly fine with 1.5. Even though I think there should be a way for the user to see what happened and to give at least an overview by date to see _that_ something happened.

  7. gregorsmith
    Member
    Posted 9 years ago #

    That makes seense... but aan option for deleting them would be nice, otherwise they will just accumulate in the db

  8. gnukerman
    Member
    Posted 9 years ago #

    I am using the 2005-02-05 1230 release with Spam Karma and found it to stop all comment spam in it's tracks.....so far.

    If you have the plugin manager installed, you can do a one click install for spam karma.

  9. Specialdark
    Member
    Posted 9 years ago #


  10. Specialdark
    Member
    Posted 9 years ago #

    I'm getting the same problem. I'm running the 1.5 public release. It doesn't really effect gregorsmith as much... but I have a "Recent Comments" plugin on my sidebar and it picks up these 'comments in limbo' and displays it on my webpage.

    You can find it here: allthingschill.com/wordpress/

    The spam comment isn't anywhere on the admin side of the blog. Is there a way to edit the comments table DIRECTLY?

    Is there a better way? I apologize for my n00b-ness. I really like having this feature. Thank you so much in advance for your help.

    Herschell

  11. The "Spam" marking is in preparation for an upcoming feature (or an upcoming plugin), probably something that will analytically evaluate the spam comments and become an "intelligent" spam filter. Rest assured, the comments no longer appear on your site.

  12. An upcoming plugin to take care it for now:

    http://wordpress.org/support/topic.php?id=23486#post-145711

  13. gregorsmith
    Member
    Posted 9 years ago #

    Cool, should make things easier than manually deleting them from the database

  14. Specialdark
    Member
    Posted 9 years ago #

    Thank you very much :)

  15. Gregor,

    An upcoming plugin to take care it for now:

    http://wordpress.org/support/topic.php?id=23486#post-145711

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.