WordPress.org

Ready to get started?Download WordPress

Forums

P2
[resolved] Comment isn't shown until refresh, AJAX? (5 posts)

  1. lewisflude
    Member
    Posted 11 months ago #

    I'm using P2 on a small community site and am having trouble getting comments to work properly. I've spent time browsing these forums for similar problems, but can't find anything that matches it.

    So, when a user posts a comment, the button is always in the "loading" state with the spinner. What I'd like to happen is for the comment to appear immediately, much like when you see other users comments appear.

    Is there an incompatibility with the latest versions of WordPress and P2?

    Would love to know what I can do to help fix this.

    Thanks for the awesome theme!

    Lewis

  2. Lance Willett
    Themer
    Posted 10 months ago #

    Hi there,
    Yes, sounds like something is wrong there -- do you have a URL we can look at to debug it? Which version of P2 are you using, and does it have any modifications?

    You can also try deactivating other plugins one by one to see if that helps.

  3. Ze Fontainhas
    Moderator
    Posted 10 months ago #

    I'm having the exact same problem on all my P2s, since 3.7 (maybe 3.7.1, not sure). I've created a user for you here: http://palheta.wp-portugal.com/ (your sd.n email)

  4. Ze Fontainhas
    Moderator
    Posted 10 months ago #

    Feel free to post anything there, I'll warn about testing.

  5. Ze Fontainhas
    Moderator
    Posted 9 months ago #

    Not a P2 issue, conflict with an old plugin that tried to notify users (Notifly)

Reply

You must log in to post.

About this Theme

About this Topic