WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Comment function disappeared (11 posts)

  1. graleh
    Member
    Posted 3 years ago #

    Hi,

    I just noticed that the comment funcion on my site is gone. I had only been updating some pages, nothing more.

    I cannot give you any further information, since I haven't done anything more than just updating pages and I have not touched the comment-box on each page.

    I have tried to overwrite my theme files (evening-shade) with fresh ones, but still no comment field at the end of each post. I thought that if I reset the files, the comment function will appear again but I was wrong :(.

    Does anyone know what could be the problem?

    Thanks in advance!

    Kind regards
    Emelie.

  2. If you haven't touched the comments function in your theme files, have you accidentally turned off the option to leave comments in your site settings?

  3. graleh
    Member
    Posted 3 years ago #

    Nopes, I haven't been to settings since I installed wordpress a long time ago. I looked at the settings now and the comment function is still on.

  4. Then I suggest you provide a link to your site and copy the contents of your single.php, index.php & comments.php files in http://wordpress.pastebin.com/ so someone can have a look directly.

  5. graleh
    Member
    Posted 3 years ago #

    I have now installed and activated another theme and deleted the theme evening-shade. I uploaded a fresh version of evening-shade again but then the comment function disappeared again! Even though it's a fresh version.

    Straaaange..

  6. graleh
    Member
    Posted 3 years ago #

    ah, let's have a try:

    single.php: http://wordpress.pastebin.com/Ad2KLDsU
    index.php: http://wordpress.pastebin.com/a7E2rt01
    comments.php: http://wordpress.pastebin.com/6v0ngTv9

    the url is http://www.undine.se
    it's in swedish but I guess the content is not neccessary ;)

    thanks!

  7. Chip Bennett
    Theme Review Admin
    Posted 3 years ago #

    It appears that your homepage is a static page. Do you have comments enabled for Pages?

    I can't find where you've got your blog posts. But then, I can't read Swedish, and GoogleTranslate is failing me. :)

  8. graleh
    Member
    Posted 3 years ago #

    Thanks for your answer, Chip :)

    I have no posts, I use pages only.
    I want my homepage/start page to be a static page, since I do not want to use my site as a blog, just a simple home page with static pages about me and my services and interests.

    The comment function works in other themes, it's just in this theme the comment function isn't working :/

    So I have all comment functions enabled in settings and on each page I want the function to be enabled in :)

    Edit:
    I tried to enable that the start page will show my latest posts and then the comment function actually shows beneath the post!! Wohoh.

    But it does still NOT show in pages! :/
    I want ppl to leave comments on my pages as well :)

  9. Chip Bennett
    Theme Review Admin
    Posted 3 years ago #

    Can you post a pastebin of your page.php template file? My guess is that it may be missing the call to comments_template().

  10. graleh
    Member
    Posted 3 years ago #

    Yep, that's correct :)
    THANKS A LOT :)

    I studied some working themes and in page.php the

    comments_template();

    function was missing so I simply inserted it in my evening-shade theme. Voilá!

    <3 thanks again <3

  11. Chip Bennett
    Theme Review Admin
    Posted 3 years ago #

    Glad you got it working! :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags