WordPress.org

Ready to get started?Download WordPress

Forums

Frontier Post
[resolved] Comment form shows on Shortcode page (9 posts)

  1. blauweogen
    Member
    Posted 11 months ago #

    I have comments turned off and even tried it on a test site and it always shows the comment form. On one site I also use Jetpack share buttons and they show when turned off for that page also. The page (My Posts) where it shows the post list is what i am referring to. Any idea on a fix? Tried to find were the problem was but couldn't

    Latest WP and latest Buddypress and default bp theme

    http://wordpress.org/plugins/frontier-post/

  2. finnj
    Member
    Plugin Author

    Posted 11 months ago #

    Edit the "My Posts" page from the back-end
    In the bottom, turn off "Allow comments" - if this options doesn't show, select Screen Options (dropdown in upper right corner) , and check Discussion checkbox

    Did the above fix it ?

    I will try and disable comments for this page on install for next release

  3. blauweogen
    Member
    Posted 11 months ago #

    Hi, thanks for the reply! Unfortunately I already have comments and share buttons turned off on the edit page. And comments are turned off for the whole site as well.

  4. finnj
    Member
    Plugin Author

    Posted 11 months ago #

    This is very strange - there is nothing in my code with comments....

    Might be some code that isnt closed correctly.

    Can you give access to you site, just to be able to create a draft post, so I can have look ?

    You can email me at: wp frontier 99, and then at gmail
    (No spaces)

    Thanks

  5. finnj
    Member
    Plugin Author

    Posted 11 months ago #

    Haven't forgot this one...

    I know what the issue is, I am just strugling to find a long lasting solution.

    Most likely I will have to rewrite the list page (incl pagination) as the page picks up the last post in the list, and if that has comments or comments are enabled for that, it will show on the page.

  6. blauweogen
    Member
    Posted 11 months ago #

    Yeah, I know sometimes it's not an easy fix. Thanks.

  7. finnj
    Member
    Plugin Author

    Posted 11 months ago #

    Hi,

    Believe I have found a permanent fix, solution was easy, I just made it too complicated :)

    The problem was that the My Post page used data from the last post listed on the page, when showing the last part of the page where comments typical are. Solution was to to restore the post data from the page after listing of the users posts.

    I have added wp_reset_postdata(); as the last line of frontier_list.php (located in forms directory.

    you can either download the development, or insert the line manually to test:

    _e('Sorry, you do not have any posts (yet)', 'frontier-post');
    		echo "</center><br></br>";
    	} // end post count
    
    //Re-instate $post for the page
    wp_reset_postdata();
    
    ?>

    You can download the development version here: Development version

  8. blauweogen
    Member
    Posted 11 months ago #

    That works beautifully! Great job and great plugin!

  9. finnj
    Member
    Plugin Author

    Posted 11 months ago #

    Fix applied in version 1.5.6

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.