WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Comment form missing (9 posts)

  1. teemio
    Member
    Posted 7 years ago #

    Hi, I'm sorry -- but when I click "comment" on my page, it brings me a new page with my post but without the comment box. It used to exist. But now it's gone. I'm a little confused. I haven't touched comments.php.

    Any ideas?
    Thanks

    http://blog.teemio.com

  2. Ryan Fitzer
    Member
    Posted 7 years ago #

    Have you turned off comments on that particular post? Have you edited single.php recently?

  3. teemio
    Member
    Posted 7 years ago #

    Hi, ryan. Thanks for your reply.

    Every post is missing the form for comments. I've checked, and comments are enabled for all.

    The particular theme I am using does not have single.php. It does have a home.php, thought. Would that be basically the same?

    At any rate, I have not edited it recently.
    Here is the code that links to the comment page--
    `<?php comments_popup_link('Comment', '1 Comment', '% Comments'); ?>'

  4. Ryan Fitzer
    Member
    Posted 7 years ago #

    If there is no single.php (where the comment form is usually included) then by default, WordPress will use index.php to display a single post. This is where you should have the comment form included. But, still, why doesn't your theme have a single.php? Have you changed themes lately? Did you accidentally delete single.php? Can you download a fresh copy of the theme and replace the old one? Single.php is pretty standard. Have yet to see a theme not use it.

  5. teemio
    Member
    Posted 7 years ago #

    well, the theme definitely does not have a single.php.
    but i made my own, and now it works.

    thank you so much!

  6. Ryan Fitzer
    Member
    Posted 7 years ago #

    Cool. Your welcome.

  7. foolswisdom
    Moderator
    Posted 7 years ago #

    Nice work ryanfitzer and teemio!

    Noting the theme is Blue Zinfandel and marking fixed.

  8. RoostersRail
    Member
    Posted 6 years ago #

    I know this post has been around for 7 months. But I just wanted to say thanks it was exactly the same problem that I was having.

    I looked in the theme folder that I had on my local machine and compared it to the one on the server and it was missing the single.php. I uploaded the one file and bingo! I now have comment boxes on my posts.

    Thank you so much.

  9. danielkwan
    Member
    Posted 6 years ago #

    For us non-designers/coders, how do you create a single.php? The theme I'm using doesn't have one either.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags