WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Comment form doesn't indent (5 posts)

  1. mwelch
    Member
    Posted 3 years ago #

    Hi All,

    I can't seem to figure this one out. I recently switched over to the default comment system (from disqus) but I'm seem to be having a problem with reply's indenting.

    That is, when someone posts a comment and a person responds to that comment; there is no indention which can distinguish that comment as a 'response' comment.

    Hope I'm making sense here.

    Here is a link to help better understand the issue:

    http://www.newbizblogger.com/social-networking/plan-your-tweets#comments

    FYI. I tried using WP Threaded Comment which was cool, however, with this plugin only response comments were showing gravatars, none for the original commentator.

    Tried adding WP Gravatars, but this only add 2 gravatars to commentators.

    Thanks in advance for any help you can give me!

  2. flamenco
    Member
    Posted 3 years ago #

    Hi,
    That's interesting... there's nothing much in the HTML to distinguish replies. The only thing I see in there is the the first comment seems to have a "mycomment" class, and all the others have the "odd" class. So if you add some CSS code to style.css like this, the "odd" ones will indent, but replies to replies don't indent more or anything. So this idea may not be so good. And it's possible my assumptions above are wrong.

    Maybe the plugin has some more settings for that somewhere.

    .odd p {
      margin-left: 30px;
    }

    Cheers, Dave

  3. mwelch
    Member
    Posted 3 years ago #

    Hi Dave,

    Unfortunately that indents ALL the comments. It was definitely worth the shot though.

    It seems to me that there are only "odd" classes, no "evens". Not sure if this is where the issue is stemming from or how to fix it.

    I've reinstalled the WP Threaded Comment, which put's things back in order. Of course, still running into the issue of no gravatars showing up for the initial commentator, just replies.

    Here is the code:
    <div class="comment-childs<?php echo $deep%2 ? ' chalt' : ''; ?>" id="comment-[ID]"><?php if(function_exists("get_avatar")) echo get_avatar( $comment, 32 ); ?><p><cite>[author]</cite> Reply:[moderation]<br /><small class="commentmetadata">[date] at [time]</small></p>[content]</div>

    Any ideas how to keep the template from calling on the gravatars with this plugin.

    This way I can install WP Gravatars and just use that.

    Thanks again!!

  4. flamenco
    Member
    Posted 3 years ago #

    Hi,
    Wow, I guess I misunderstood, or misunderestimated you. :) Gee, I'm looking at your pages now, and all the comments look great with gravatars, replies or not. :)

  5. mwelch
    Member
    Posted 3 years ago #

    Hi Flamenco,

    Thanks for the reminder. I usually try to make it a point to come back and post any findings in case others come across the same issue.

    I basically fussed around with the comment section of the theme. Apparently the problem seemed to be with a conflict b/t WP Threaded Comments & WP Gravatars, looks as if Gravatars were only showing for logged in users.

    Can't remember off hand right now what I did...will post back next week with the results. Off to an event now! ;-)

    Thanks again for your help!

Topic Closed

This topic has been closed to new replies.

About this Topic