WordPress.org

Ready to get started?Download WordPress

Forums

Comment Author's E-mail (8 posts)

  1. Sandman
    Member
    Posted 9 years ago #

    I am using 1.2b, and was wondering how I get the comment authors' e-mail addresses to show up when an e-mail is sent to me when they comment.
    e.g. - Joe comes to my site, and comments. He enters his e-mail address, but it is not displayed on the site - however, when that e-mail is sent to me, the from box is empty, so when I reply - there is no address in the to: box.
    Thoughts?

  2. carthik
    Member
    Posted 9 years ago #

    When the commenter leaves an email id, that is the reply-to address in the mail sent that contains the comment.

  3. Sandman
    Member
    Posted 9 years ago #

    Actually, it isn't - it's always blank.
    Under my comments section, WP says:

    Line and paragraph breaks automatic, e-mail address never displayed, HTML allowed...

  4. carthik
    Member
    Posted 9 years ago #

    Sandman, this could be a "bug" then. Let me check on my beta blog.

  5. carthik
    Member
    Posted 9 years ago #

    I got this mail when I posted a comment on my beta blog using the email address mail@2fargon.com
    The commenters address shows in two places, though not in the "from" field...

    From: "Carthik" <mail@2fargon.com>
    Content-Type: text/plain; charset="utf-8"
    Message-Id: <E1BKgAG-00054d-00@smtp.perfora.net>
    Date: Mon, 03 May 2004 12:19:32 -0400
    X-Provags-ID: perfora.net abuse@perfora.net auth:not_set
    New comment on your post #1 "Hello world!"
    Author : Carthik (IP: 24.110.13.141 , user-0c6s3cd.cable.mindspring.com)
    E-mail : mail@2fargon.com
    URI : http://2fargon.com
    Whois : http://ws.arin.net/cgi-bin/whois.pl?queryinput=24.110.13.141
    Comment:
    nothing much actually.
    You can see all comments on this post here:
    ">http://2fargon.com/beta/index.php?p=1#comments`
    I use Moz Thunderbird to check mail.

  6. carthik
    Member
    Posted 9 years ago #

    Click on the mailto link in the comment email that you get. This follows the "Email: " in the mail sent to you.

  7. Sandman
    Member
    Posted 9 years ago #

    Yeah, but why is it left out in the "Reply-to:" or simply "From:" part of the e-mail?
    It's simply blank, and only started doing that with v1.2b.
    Perhaps it is a bug of some sort, or a feature I can disable?

  8. carthik
    Member
    Posted 9 years ago #

    It could be improved the way you say it. Leave a comment in the beta testing thread so the devs can see it and fix it.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.