WordPress.org

Ready to get started?Download WordPress

Forums

Ultimate Coming Soon Page
[resolved] Coming soon page shows even when logged in (wordpress subdomain install) (8 posts)

  1. jdaviescoates
    Member
    Posted 5 months ago #

    Hi there,

    I've wordpress installed in a subdirectory, e.g. http://example.com/wordpress/

    In General -> Settings I've got:

    WordPress Address (URL): http://example.com/wordpress/
    Site Address (URL): http://example.com

    Seemingly this stops this plugin functioning as intended, i.e. the coming soon page is displayed whether or not I'm logged in.

    How can I fix this so that when I'm logged in I can see the site I'm developing?

    Thanks,

    Josef.

    https://wordpress.org/plugins/ultimate-coming-soon-page/

  2. jdaviescoates
    Member
    Posted 5 months ago #

    PS I'm using wordpress 3.8.1 and 1.10.1 of the plugin.

  3. John Turner
    Member
    Plugin Author

    Posted 5 months ago #

    I have seen this many times and it's always a mis configuration with the WordPress sub folder setup or the domain mapping plugin. If you remove the plugin you'll notice that you don't see the admin bar when on the theme and logged. A telltale sign of an issue.

    Just make sure you follow these instructions when setting up a subfolder install:
    https://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

  4. jdaviescoates
    Member
    Posted 5 months ago #

    You are correct that if I disable the plugin and go to http://example.com I do see the theme but don't see the admin bar.

    However, I have followed those instructions at http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory#Using_a_pre-existing_subdirectory_install so not sure what to do? :(

  5. John Turner
    Member
    Plugin Author

    Posted 5 months ago #

    I'd search the forums> I have seen many with this issue. When it's not configured correctly the core WordPress function called is_user_logged_in does not work correctly. Any plugin or theme that use that function will not work correctly.

    So I can be of more help :(

  6. jdaviescoates
    Member
    Posted 5 months ago #

    I started again from another clean install.

    At first it still didn't seem to work again.

    Then, even though I kept changing the permalink structure, no .htaccess was visible in my FTP client in either / nor /wordpress/.

    However, eventually, a .htaccess file did appear and everything started working. Possibly some odd caching issues with the mobile dongle I'm on.

    I note however, that now there is no .htaccess file in /wordpress/ just one in the root folder, so perhaps it was having one in each that caused the problem before? /me shrugs

    Either way, at least I've got it working now.

  7. John Turner
    Member
    Plugin Author

    Posted 5 months ago #

    Interesting, good to know! Thanks for posting your resolution. I'm sure it will help someone in the future with the issue.

    Cheers!

  8. Tim
    Member
    Posted 3 months ago #

    Thanks for the details. I posted the same problem (never had it before, do this all the time).

    I'll see if the .htaccess issue explains my problem. I'll look for this first, if I ever have this problem again.

Reply

You must log in to post.

About this Plugin

About this Topic