WordPress.org

Ready to get started?Download WordPress

Forums

Coming Soon... (5 posts)

  1. pubwvj
    Member
    Posted 9 months ago #

    "For WordPress 3.7 we decided to shorten the development cycle and focus on a few key improvements."

    Good. But lets make sure each is very, very stable. Every time we have to update it is scary because what if my theme doesn't work, plugins don't work or simply WP doesn't work?!? Thus I always wait to see what happens while others upgrade. I would rather not be the first penguin and lion seal chow.

    "Automatic, background updates. 3.7 Beta 1 will keep itself updated."

    VERY SCARY! See above. This should be turn off-able.

    Speaking of updates, WP should make sure it is backward compatible. A plugin that works today with version 3.6.1 should work in the future with future versions. A theme should not be broken by new versions of WP. If WP breaks the tools we need then upgrading becomes either:
    1) A pain in the butt - Might not do it.
    2) Impossible - Won't do it

    "Search results are now ordered by relevance"

    Great news! Shouldn't break anything...

  2. Andrew
    Forum Moderator
    Posted 9 months ago #

    Don't worry, each release has a beta stage where plugin and theme developers can check to see if their products are compatible. The good ones do check for this.

    Before you choose not to upgrade WordPress make sure you consider a compromise between the chances of having a broken site and being hacked.

  3. pubwvj
    Member
    Posted 9 months ago #

    That is not at all reassuring. The reality is many developers don't do this. Many plugins and themes are abandoned. This means that users must check their own and if a plugin on theme won't work then we're stuck. I don't want to have to switch to a new theme for my blog just because TwentyTen is no longer actively supported. TwentyTen is a beautiful example because it was included with WP as the default yet is subject to just this sort of problem. New versions of WP shouldn't break old themes and plugins.

    The security mantra is a poor excuse that keeps getting trotted out. Legacy support is too important to be run over by such dogma.

  4. Andrew
    Forum Moderator
    Posted 9 months ago #

    The security mantra is a poor excuse that keeps getting trotted out.

    Why do you think I'm trying to excuse WordPress? I don't work for them. I was just trying to help you out because it sounded like you were considering not upgrading. WordPress really does have to update its security to keep a step ahead, so I'm not sure why you don't believe this.

    As a final comment I'd like to say that asking the core developers to also make every theme/ plugin compatible is not feasible.

  5. pubwvj
    Member
    Posted 9 months ago #

    I'm suggesting that as a WP needs to make a greater effort for legacy support.

    Core should not change such that things that were compatible and followed the rules become incompatible. The theme 2010 is a prime example of this.

    The engine can change but the themes and plugins that are the interface to the users, the readers, should be able to still be used.

    Security =|= legacy issues.

Reply

You must log in to post.

About this Topic