WordPress.org

Ready to get started?Download WordPress

Forums

ComicPress and comments. (10 posts)

  1. fokjulle
    Member
    Posted 7 years ago #

    I am running a ComicPress theme on my WordPress blog, but even though comments are allowed for Pages, comments don't appear, nor is there a comment field for comments to be recorded. By default, comments are only allowed for primary blog entries (Posts).

    How do I enable comments for Pages?

  2. Samuel B
    moderator
    Posted 7 years ago #

  3. fokjulle
    Member
    Posted 7 years ago #

    Fantastic. I searched for a thread like that, but didn't find it. Working now - thank you.

    I now have a second, but related, query:

    1. When a link to a Page is clicked, the Page opens.
    2. At the bottom of the Page, the comments field will be visible, assuming the 'allow comments' box is ticked.
    3. If there are comments, they are automatically visible.

    How do I adjust the code such that the comments are not automatically visible. Instead, I want what the index page sees by default: '3 comments', or '10 comments' (etc) to appear at the bottom of the Page. Then, one must click on the '3 comments' link for the Page to reload with the comments now visible (exactly like a normal blog Post).

  4. fokjulle
    Member
    Posted 7 years ago #

    No one knows?

  5. spencerp
    Member
    Posted 7 years ago #

    You mean, something like this guy's here:
    http://kashou.net/blog/

    Has the Show Comments link, once clicked on.. it shows the comments right under his posts.. Then when you click Hide Comments, they go hidden again?

    If that's what you're referring to, here's his plugin for it:
    http://kashou.net/blog/inline-ajax-comments

    spencerp

  6. fokjulle
    Member
    Posted 7 years ago #

    That's a sexy plugin, but not quite what I meant.

    My URL is http://www.urbantrash.co.za

    1. When viewing the index page, there is a link at the bottom of the blog post linking to the comments. When clicked, the page opens showing all the comments. In other words, the comments, by default, are not displayed (to avoid lengthy scrolling).

    2. However, when a nav link is clicked (e.g; "Extras"), the Page opens with its content, including the comments at the bottom. The comments are immediately visible without the need to click on the comments link.

    Basically, I simply want it to look the same as the index page, where the comments are not displayed unless clicked.

  7. spencerp
    Member
    Posted 7 years ago #

    Well, the easiest thing to do is, in Control Panel => Manage => Pages.. while "editing" that page, on right side there.. at top, under: Discussions section, make sure the "allow comments" check box, is unchecked.. then save page.

    This will keep anyone from posting comments on pages. =) Unless you REALLY want comments on pages, then..I'm not too sure on how to do, what you want.. never did it before lol!

    spencerp

  8. fokjulle
    Member
    Posted 7 years ago #

    Yip, I want comments on certain pages :- ).

    Why do the comments on Pages get displayed by default?

  9. spencerp
    Member
    Posted 7 years ago #

    It's because the "pages" are using a certain theme file, by default, that contains "calls" for the "comments.php" file, which shows your comments/comment form.

    Someone, correct me if I'm wrong or whatever, please lol. As for editing that stuff, to work the way you want it to, I'm not sure off hand.. I'm in the middle of doing someone's WordPress installation at this time..

    Hopefully someone can jump in here, with more PHP coding experience then me.. to help ya with it lol.

    spencerp

    You could assign "page templates" to each "page" with specific codes for specific things though..

  10. Chris_K
    Member
    Posted 7 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags