WordPress.org

Ready to get started?Download WordPress

Forums

comfy theme: featured images not showing.... (56 posts)

  1. rgedit
    Member
    Posted 2 years ago #

    hi guys

    You might say go and ask the developers and company who has sold this to you, but not getting any help from there, many other users are asking for help, but no reply from support.

    Here is my issue:
    I need some help with the issue of the image:
    this is my website: http://www.afghans.com.au

    when you go to this website you can't see the images under 'Featured Stories', on the top, you can see the number '1' and '2' but no images shown.

    I am using this image: http://www.afghans.com.au/images/valy_awb1.jpg

    I have used the custom field 'Featured' in the post that I have created, in the past I had made the posts and the images were showing, but recently its not. Even if I make the old posts as featured, the images are not showing up.

    The only thing different I have done is that I have updated my WP to 3.2.1 so I wonder if thats done anything?

    I hope I can get some help from here.

    Please help out asap.

    Thank you so much.

  2. rgedit
    Member
    Posted 2 years ago #

    Hi Guys
    Is there anyone in who can HELP?????

    Thanks

  3. Marventus
    Member
    Posted 2 years ago #

    Hi,

    Are you sure that your theme works with custom fields for the featured posts? Most themes nowadays work with a featured category. Did you try creating a featured category and adding it to some of your posts?
    Also, don't forget to set a Featured image in the post editing window to all your posts.

    Let me know if that helps.

  4. rgedit
    Member
    Posted 2 years ago #

    Thank God,

    Hi Marventus

    yes, the theme does work with the featured posts because I have used it in the past, it stopped working after the update of the WP to 3.2.1

    I do have a category called FEATURED and I have added it to it.

    yeah the address is there for the FEATURED IMAGE, as mentioned before it used to work fine until I did the update for WP, which I regret now.

    thanks for your help

  5. Marventus
    Member
    Posted 2 years ago #

    Ok. I took a look at your problem.
    The Bad News:
    The theme slideshow on the version I had access to (3.1) is basically broken. It seems the folks over at Deluxe Themes used to resort to custom fields to retrieve the images for the featured posts. Later on, they updated their slider to work with a featured category, but they did not update the php code that should be retrieving the correct image path (i.e., the src attribute of the image tags).

    The Good News:
    This is totally fixable. To do so, open up the file templates/index.featured.php locally in a text editor, look for this code (on line 17):

    <a href="<?php the_permalink(); ?>"><img src="<?php echo get_post_meta($post->ID, 'featured', true); ?>" alt="<?php the_title(); ?>" title="<?php the_title(); ?>" width="662" height="230" /></a>

    and replace it with this one:

    <?php $feat_image_url = wp_get_attachment_url( get_post_thumbnail_id($post->ID) ); ?>
    <a href="<?php the_permalink(); ?>"><img src="<?php echo $feat_image_url?>" alt="<?php the_title(); ?>" title="<?php the_title(); ?>" width="662" height="230" /></a>

    You also need to have a featured image assigned to a post in order for the slideshow to work. Once that is done, turn on your slideshow back on and enjoy your awesomeness, :-)

    Oh, BTW, in their site, Deluxe Themes promises support for life for purchasing this theme. If they offered it to you too, and if they are located in the U.S. or Canada, you can file an official complaint at the Better Business Bureau for false advertising and the likes, if indeed they are failing to provide their users with adequate support.

  6. rgedit
    Member
    Posted 2 years ago #

    Hi Marventus

    Thanks so much for your help, I really appreciate your help.

    I did the changes, now the code for index.featured.php looks like this:
    _________________________
    <?php while ($features->have_posts()) : $features->the_post(); ?>
    <div class="pane">
    <?php $feat_image_url = wp_get_attachment_url( get_post_thumbnail_id($post->ID) ); ?>"><img src="<?php echo $feat_image_url?>" alt="<?php the_title(); ?>" title="<?php the_title(); ?>" width="662" height="230" />
    <span class="overlay"></span>
    _______________________________________________

    but there is a bad news, looking at some of the thread of other users at deluxe themes support, i went to DT>General Options>Video Setup>"Selected: NONE (Will disable this font....."

    Since I didn't get any help I un ticked the option "Enable the brand new featured slideshow which uses large images." so that there is not featured stories number without any images.

    I went and did the changes and went back to this settings and enabled the slideshow and turned the video setup to featured and when refresh the website, it only shows that header section and then ONLY the featured module with no image or text shows up, I mean I can email you a snapshot if you can provide me your email address?

    When I un tick the option of FEATURED SLIDESHOW under the general options and refresh the website, I see everything back to normal with no featured items.

    not sure what to do now?

    thanks
    I really appreciate that you have taken your time to look into this issue for me.

    Select "videos" category

  7. Marventus
    Member
    Posted 2 years ago #

    I did some further testing, and turns out I was wrong about the custom types being an oversight. They are actually quite intentional, since there are two versions of the slideshow that work equally well:
    1. The oold one, which works with a featured category that is selected from the dropdown box Select "featured category". To turn on the old slider, the "Enable the brand new featured slideshow which uses large images" checkbox needs to be unchecked.
    2. The new one, which works with a "featured" custom field with the full image path as its value. To turn this one on, the "Enable the brand new featured slideshow which uses large images" needs to be checked.

    I guess they did it this way so that users can set very wide images in the slideshow without worrying about how they would look in their thumbnail sizes inside posts and stuff.

    Bottomline, you have three choices:
    1. Use the old slider with a featured category;
    2. Use the new slider with a "featured" custom field. In that case, you would have to undo the changes I suggested in my previous post;
    3. Use the new slider with a featured category, in which case you can keep the changes.

    Here's a screenshot of what each slider looks like:
    1. Old slider;
    2. New slider.

  8. rgedit
    Member
    Posted 2 years ago #

    Hi Mrventus

    Thanks for the researched, what I did was undo the changes, go back to the general options and then ENABLED the FEATURED SLIDESHOW,

    Like you have mentioned above, the featured custom field has the full url of its value because it has the thumb value too, which you can see on the main, page.

    I am back to where I had started, the slides does not show the images.

  9. Marventus
    Member
    Posted 2 years ago #

    Hi,
    Even though the new slider uses a custom field to retrieve the image url, it also needs a "featured category" to retrieve the posts in question, so you also have to specify a featured category in "Select featured category".
    Also, how are you going about adding your custom fields? They are set from the post editing window. If you can't see the custom field option set, click on the "Screen Options" at the top of the post editing window, right under where it ways "Howdy, [username]", and check the "Custom Field" checkbox along with any other ones you desire. You should then be able to see the option set fine.
    Once you do, click on "New", and enter "featured" under "Name" and the full path to the image for that post under "Value". You will have to do that for every post you wish to display in the slideshow.
    Here is a screenshot of how to do it.
    After doing that, your slider should work as expected.

  10. rgedit
    Member
    Posted 2 years ago #

    Hi Marventus

    I have been doing exactly what you have mentioned above, so below are the screenshots of those things, but still the slider not working.

    Categories: http://imagebin.org/182236

    Custom field used: http://imagebin.org/182237

    Screen shot: http://imagebin.org/182238

  11. rgedit
    Member
    Posted 2 years ago #

    Hi Marventus

    Sorry, I missed the SELECT FEATURED CATEGORY screen shot, which is: http://imagebin.org/182247

    you know the custom field used: http://imagebin.org/182237
    you can see that the thumb in the custom field is working fine because on the website the thumbnail can bee seen.

    thanks

  12. Marventus
    Member
    Posted 2 years ago #

    Ok, I see.
    What I find confusing, and possibly a sign that you might be missing smth, is that it is not just the image that is not being displayed in your slideshow, since the title, excerpt and number of comments should also be showing up, and they are not.
    Check out my test site. I set it up to use the new slider (with custom fields). The first post has a custom field "featured" set to it, but posts 2 and 3 do not. However, even though there is no image for these posts (2 and 3), the other information is being displayed regardless.
    Also, I was thinking that perhaps when I had you edit the templates/index.featured.php file, you did not restore it back to its original version. Just in case, make sure lines 16 to 24 of that file match the following ones to the letter:

    <?php while ($features->have_posts()) : $features->the_post(); ?>
    <div class="pane">
    <a href="<?php the_permalink(); ?>"><img src="<?php echo get_post_meta($post->ID, 'featured', true); ?>" alt="<?php the_title(); ?>" title="<?php the_title(); ?>" width="662" height="230" /></a>
    <span class="overlay"></span>
    <a href="<?php the_permalink(); ?>" class="title"><?php the_title(); ?> ยป</a>
    <a href="<?php the_permalink(); ?>" class="info"><?php echo substr(get_the_excerpt(),0,120).'...'; ?></a>
    <a href="<?php the_permalink(); ?>#comments" class="comment"><?php comments_number('0','1','%'); ?></a>
    </div>
    <?php endwhile; ?>
  13. Marventus
    Member
    Posted 2 years ago #

    The image path you are entering for the custom field is correct, since I can see the image fine.
    Are you clicking on "Update"or "Save" in the Post Editing window after adding the custom fields and categories to your posts

  14. rgedit
    Member
    Posted 2 years ago #

    Hi Marventus

    Yes you are right, thats what I believe it shoudl do too.

    I just copied the above code back to the index.featured.php file this time i went to the admin of WP and through editor i changed it.

    anything else we can do?

    thanks for your help, really appreciate it.

  15. rgedit
    Member
    Posted 2 years ago #

    Yes, I am clicking on update, and even I tried to do a new post with the same address, etc, it still didn't show anything......

  16. rgedit
    Member
    Posted 2 years ago #

    Can I ask, which version did you use for the test website you have done? v3 or v4?

  17. Marventus
    Member
    Posted 2 years ago #

    I'm using version 3.1, just like you. I also compared your slideshow HTML with mine, and it is strictly identical. The only difference between your setup and mine that I can see, is that my theme folder is called comfy-pro, while yours is comfy-3.1.
    Let's try something: Try to access your site through FTP, backup your current comfy theme on your computer (i.e., download it from the server), and then try redownloading the entire theme from Deluxe Themes or your e-mail address (depending on how it was delivered to you) and upload it to your server again.

  18. rgedit
    Member
    Posted 2 years ago #

    ok so you want me to download all the files from the server, and then use the original theme files to upload and to the folder? or do I need to re-install the WP from scratch? also after download, do I need to delete the files? what about my posts, my plugins, etc, will I loose them? do you have an email address?

  19. Marventus
    Member
    Posted 2 years ago #

    You do not need to reinstall WordPress. Here's a more clear walkthrough:
    1. Download your current Comfy theme from your server to your computer. We will use this as a backup. It should be located under http://www.afghans.com.au/wp-content/themes.
    2. Delete the comfy theme folder from your server (comfy-3.1 folder).
    3. Reupload the comfy theme that was delivered to you or that you downloaded from Deluxe Themes to the server (themes folder).
    Your plugins,WP core files, and database won't be affected by this, and you should also keep all your Comfy options, because those are stored in the DB, not in the installation files.

  20. rgedit
    Member
    Posted 2 years ago #

    Hi Marventus

    I just made a backup, then deleted the the comfy-3.1 folder then uploaded it again as comfy-3.1 folder to the server and refresh the website, still nothing happened, it the same as before.

  21. Marventus
    Member
    Posted 2 years ago #

    Actually, I just checked it out and now it's working fine!
    Empty your cache (ctrl+Shft+Del on most browsers) and refresh the page.

  22. rgedit
    Member
    Posted 2 years ago #

    Yeah I tried a different internet exlora and its working, thank you so much, but I do see some changes such as the logo, what do I do or how i know what are the changes? I need to do?

    thanks so much

  23. Marventus
    Member
    Posted 2 years ago #

    Ok. In that case, try to reupload the images folder (comfy-3.1/images) from the backup on to the site.
    That should restore your logo.

  24. rgedit
    Member
    Posted 2 years ago #

    Thank you so much Marventus, I don't know how to thank you, thanks so much and good luck for everything in the future, but can I ask you something can anyone see the my theme, files, images, etc, if yes, anyway of stopping that? or hiding it? in any case, how do you access it?

    thanks

  25. Marventus
    Member
    Posted 2 years ago #

    You are welcome. You might also want to reupload the following folders just in case changes had been made to the files inside:

    • styles
    • user-preferences
  26. Marventus
    Member
    Posted 2 years ago #

    For your security question, make sure you have an .htaccess file in your root directory (i.e., afghans.com.au). If you do, download it to your computer. If you don't, create a file called htaccess.txt on your computer.
    Add the following code inside the file at the top:

    Options All -Indexes

    And upload it to your site. Rename the htaccess.txt file to .htaccess on the server in the second case.
    Also, here's some Codex articles on how to strenghten security inside WP.
    Hardening WordPress
    htaccess for subdirectories

    Good luck to you too!

  27. power47
    Member
    Posted 2 years ago #

    I have a problem and would like to ask if I can help

  28. Marventus
    Member
    Posted 2 years ago #

    Hi,

    I can help you, but if your problem is not related to the original poster's, you need to open your own topic.
    Also, you seem to be new to the forums, so I would recommend that you read this article, which describes the forum guidelines: Forum Welcome.

  29. power47 - Please make your own topic for your issue. Your posts are pending moderator approval and we will not approve your posts for this topic, as you need your own help and not to thread-jack someone else.

  30. Marventus
    Member
    Posted 2 years ago #

    Amen!

Topic Closed

This topic has been closed to new replies.

About this Topic