WordPress.org

Ready to get started?Download WordPress

Forums

.com to .org migration - url problem (18 posts)

  1. Marc
    Member
    Posted 7 years ago #

    Background: I have 3 blogs running via WP.org under a single domain.

    I also have had a WP.com blog that I successfully imported (using Aaron Brazell's plugin) to a new WP.org blog also under the same domain.

    The domain is cranialcavity.net. The migrated blog should be cranialcavity.net/motorsports and that is how it's displayed on the options page in the "WordPress address (URI)" and "Blog address (URI)" blocks.

    However if you call up that url it displays the index page of the base url, cranialcavity.net which is one of the other blogs on the domain.

    I attempted to change the url in the "WordPress address (URI)" block to read cranialcavity.net/motorsports/index.php and after the change it bounces you to the correct blog but it contains no styling just plain text.

    I have since emptied the database and reinstalled and await a possible solution to this problem.

    Any ideas?

  2. Marc
    Member
    Posted 7 years ago #

    No takers yet?

    That's OK, sooner or later someone will.

  3. Marc
    Member
    Posted 7 years ago #

    Still no interest in this problem. Oh well not that it makes much difference at the moment.

    My host has decided that it would be "nice" to crash the server I'm on.

  4. vkaryl
    Member
    Posted 7 years ago #

    Oy.... Marc, it's not that I have no interest, just that I have no experience with the problem.

    And maybe you ought to consider a different host?

  5. Firas
    Member
    Posted 7 years ago #

    Get in phpmyadmin and update the 'home' and 'siteurl' values in your options table.

  6. Marc
    Member
    Posted 7 years ago #

    Thanks vkaryl, I didn't expect a response from someone with no experience with the problem. Funny thing is, actually sad, I had this problem once before in setting up my original WP blog after moving away from MT three years ago.

    Firas, I'll give your suggestion a shot when the site comes back up. Normally the host is pretty reliable, only 4 outages in 3 years. But this time even the hosts site is down.

  7. spencerp
    Member
    Posted 7 years ago #

    I was going to jump into this one, as soon as I seen it. But, wasn't really sure myself sigh. =/ My first thought was, to do as Firas said above there. But again, wasn't really sure..

    By the way Firas, I added Podz's guide link to your reply there, just wanted to let you know... ;) Yeah, when adding the /index.php onto the ends of the URL's, in the two URI fields, under Options => General

    Things won't work as thought.. But, yeah, like Firas said above.. you'll just be making sure, that both URLs in the database are pointing to: cranialcavity.net/motorsports

    Hopefully things will workout for you Marc. ;) Looking forward to seeing your reply, updating us on this issue. ;)

    spencerp

  8. Marc
    Member
    Posted 7 years ago #

    Thanks spencerp will do if my site ever comes back up.

    The reason I attempted to add "index.php" at the end of the url is it will actually call-up the blog if you use the entire url i.e. cranialcavity/motorsports/index.php

    Without that "index" suffix it trashes the entire blog, even the dashboard.

  9. spencerp
    Member
    Posted 7 years ago #

    Yeah.. Hmm.. I notice when going here:
    http://cranialcavity.net/wordpress/index.php

    It will show your content fine. But.. when going here:
    http://cranialcavity.net/wordpress/

    Shows the blog's 404.. =/ Let me think about this a minute.. Maybe someone else, like Kaf, Handy or someone might know of it..maybe if they see this, they'll know right off the bat.. I'll think about it .. ;)

    spencerp

    /I was thinking there before, about it maybe might be an .htaccess problem. Maybe try deleting the current one there, if you have it.. upload a blank one.. and rebuild the .htaccess file once? I think I had this same problem before, with someone's install, when doing an install4free request.. =/

  10. Marc
    Member
    Posted 7 years ago #

    No go Firas! I followed Podz instructs to the letter, no change is the result.

    In fact both fields when called up in phpmyadmin were correct.

    The 'siteurl' option_name was set to cranialcavity.net/motorsports

    And the "Home" table also was at cranialcavity.net/motorsports

    As a precaution I saved each as they were written but it resulted in no change in blog behavior.

    Anyone else want to take a stab at the problem?

    Is it possible because I have not set my permalinks that my contribute to or be that cause? Currently they are set at the default (?p=xxx)

    Oh joy.... just noticed going to the Dashboard ver 2.0.5 has been released. Guess I should have waited 24 hours to start this move and with the latest WP ver.

  11. Marc
    Member
    Posted 7 years ago #

    spencerp... that the exact problem.

    When going to cranialcavity.net/motorsports it's actually redirecting to the base blog on the domain. The 404 is the result of not being on the same datebase I assume.

    Add the index.php to that url and you arrive in the correct place Asian Motor Sports.

    Go figure.

  12. Marc
    Member
    Posted 7 years ago #

    Let me rephrase that spencerp. The base blog on the domain is cranialcavity.net/index.php, a political blog

    The blog I have migrated over from WP.com is Asian Motor sports, and it should display at cranialcavity.net/motorsports.

    However it doesn't it redirects to the political blog plus the 404 because they are on two different databases.

    When adding .index.php to the motorsports url it calls up the correct blog with the correct database.

    Hope that straightens out any confusion.

  13. spencerp
    Member
    Posted 7 years ago #

    Thanks for clearing things up for us Marc. ;) Um, I could have sworn I had helped someone with a problem similiar to this one, just I can't find it at the moment sigh. It's buried in under my profile pages some where.

    I actually went into the guy's blog control panel and FTP directory.. working on the .htaccess file, to make things work for him..

    Umm..What moshu says here, the number 2, that is:
    http://wordpress.org/support/topic/70575?replies=3#post-370899

    Not sure if that might give some ideas.. Also, can you paste a copy of your .htaccess file in here please? =) Just for reference purposes.. I'll post a plain jane copy of a .htaccess file, that would be for a blog in a subdirectory (sub folder)of a domain name.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /motorsports/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /motorsports/index.php [L]
    </IfModule>

    # END WordPress

    I'm not sure what your's has though, but..that's what it should look like, I'm assuming..? I hope someone else would stop in here and throw some of their 2 cents around lol! =P ;)

    spencerp

  14. Marc
    Member
    Posted 7 years ago #

    This is what is in it now. Note, I updated the permalinks to cranialcavity.net/motorsports/post title and the following is what WP gave for the .htaccess.
    ~
    RewriteBase /motorsports/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /motorsports/index.php [L]
    </IfModule>
    ~

    Also it gave the "if your file was writable" if you know what I mean. Obviously because the motorsports dir didn't have one. I created one with the code given and the new p-link structure was created. BUT the problem still persists AND individual posts give a 404.

    I'll go in a use your code to see what that does.

  15. Marc
    Member
    Posted 7 years ago #

    Again, no luck with your code spencerp.

    It still kicks over to the base blog. when you add "index.php" to the url in the address bar it displays the correct blog however the individual posts still return a 404.

    I've got to take a couple hours break at the moment before my head explodes. With luck another idea will pop into the thread.

  16. Chris_K
    Member
    Posted 7 years ago #

    My eyes kinda glossed over as I tried to sort through this, so I'll just ask one clarifying question: If the blog in the root of your site is set to Default Permalinks, can you get to the others?

    Oh, and how about:
    On the blog that you're using "index.php". Clear it out of the Options -> General URI fields and instead, try "almost pretty" permalinks with a custom string (in other words, start the string with index.php/)

  17. Marc
    Member
    Posted 7 years ago #

    1. It doesn't seem to matter how the permalinks are set in the root blog. And to clarify, the only blog that is having the problem is one just imported from WP.com. The other three on the domain are ok.

    2. I'll give the almost pretty idea a shot. I have been reluctant to mess with the options section again. Last time I did it trashed the entire blog and I had to clear the database and reimport data from WP.com blog.

  18. Marc
    Member
    Posted 7 years ago #

    For everyones general interest this problem was solved via finally getting the .htaccess code entered correctly.

    Specifically a modification of spencerp's code above.

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /motorsports/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /motorsports/index.php [L]
    </IfModule>

    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^motorsports.cranialcavity.net$ [OR]
    RewriteCond %{HTTP_HOST} ^www.motorsports.cranialcavity.net$
    RewriteRule ^(.*)$ http://cranialcavity.net/motorsports/index.php [R=301,L]

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.