WordPress.org

Ready to get started?Download WordPress

Forums

The Events Calendar Category Colors
[resolved] Colors not appearing (22 posts)

  1. rockytt
    Member
    Posted 1 year ago #

    Just started using this plugin and have (finally) been able to see the correct color(s) in the dashboard at >events>settings>category colors but nothing changes on the calendar itself. What can I try next?
    http://tech4realtor.com/glaaacc/events/2013-02/

    Thanks!

    (using latest version btw...)

    http://wordpress.org/extend/plugins/the-events-calendar-category-colors/

  2. Andy Fragen
    Member
    Plugin Author

    Posted 1 year ago #

    rockytt, very interesting. The plugin seems to be generating the proper css. Did you happen to add the gist code I mentioned in the FAQ to you functions.php? I ask because it looks like your event is being stripped of its category class tag. And that seems to be the problem.

  3. rockytt
    Member
    Posted 1 year ago #

    Hi Andy-
    I had not, but adding it in doesn't seem to make any difference (that I can see-browser cache has been cleared)

  4. rockytt
    Member
    Posted 1 year ago #

    (remove_tribe_cat_once.php)

  5. Andy Fragen
    Member
    Plugin Author

    Posted 1 year ago #

    I don't want you to add remove_tribe_cat_once. It looks like it's there. I'll try to get back to this thread throughout the day but my day job interferes. ;-)

    BTW, just for fun, update to current version. You're only one behind. ;-)

  6. rockytt
    Member
    Posted 1 year ago #

    That was fun :)

    Was there a different function I was supposed to add?
    Totally understand about day job - I'll be patient :)

  7. Barry Hughes
    Member
    Plugin Contributor

    Posted 1 year ago #

    Hi rockytt, interesting. As Andy said it seems the category class is missing which means this plugin can't work its magic.

    • Just to be clear, you do not have the remove_tribe_cat_once() function in place any more (hopefully you do not)?
    • Do you happen to be using a caching plugin such as W3 Total Cache or WP Super Cache, or a cache that operates above WordPress's level?
    • Have you customized your event templates at all?
  8. rockytt
    Member
    Posted 1 year ago #

    Hi Barry,

    Well, in Andy's first post he said to add the gist code, and when I followed the link at the FAQs it gave me the remove_tribe_cat_once() function. Was there something else I should have done instead?
    Didn't work whether it was in place or not, but I'll go ahead and remove it.

    No caching
    Have customized the small calendar on the home page a tiny bit, but not the main one.

  9. Barry Hughes
    Member
    Plugin Contributor

    Posted 1 year ago #

    Yeah I think there was a slight misunderstanding there. Please do remove that function, for the time being at least - then let's see how it all looks at that point.

  10. rockytt
    Member
    Posted 1 year ago #

    Yup - same as before my first post (and Andy's response) - I'm sure I just missed something obvious, but for the life of me can't figure out what it is-
    (Need to have more than one category/event setup?)

  11. Barry Hughes
    Member
    Plugin Contributor

    Posted 1 year ago #

    I do also note the tooltip for that event in February isn't displaying when you hover over it (in month view) ... if that isn't something you've customized could it be there is a conflict somewhere along the line?

    Are you in a position to run through the usual troubleshooting steps (deactivate other plugins and switch back to Twenty Eleven or Twenty Twelve, check if that solves the problem and reactivate one-at-a-time until the problem returns)?

  12. rockytt
    Member
    Posted 1 year ago #

    Deactivated everything except the 3 Events Calendar plugins, switched to Twenty Twelve, and still no color for the Feb event-

  13. Barry Hughes
    Member
    Plugin Contributor

    Posted 1 year ago #

    Ok. Is it possible for you to do that again, leave it in that state and let me know (I'm around for the next 30mins if you are) so I can see how the markup looks?

  14. rockytt
    Member
    Posted 1 year ago #

    Sure - here's a link to the calendar page -
    http://tech4realtor.com/glaaacc/events/2013-02/

  15. Barry Hughes
    Member
    Plugin Contributor

    Posted 1 year ago #

    Thanks - while you're still on, can you now deactivate The Events Calendar Category Colors then post back again?

  16. rockytt
    Member
    Posted 1 year ago #

    done

  17. Barry Hughes
    Member
    Plugin Contributor

    Posted 1 year ago #

    OK, go ahead and reactivate everything to get it all back on track: thanks for working through that with me.

    So I don't think this is a problem with this plugin. Here's why: even when it isn't running, the div that contains the individual events in the grid view is completely devoid of CSS classes.

    Normally, each event within each table cell is wrapped in something called a div, and the opening tag (in a default installation) ought to look like this:

    <div id="event_123-18" class="post-123 tribe_events type-tribe_events status-publish hentry tribe-events-event tribe-events-real-event cat_your-category entry">

    Noting all of that class="..." stuff that is present in my example. This is the equivalent on your site:

    <div id="event_419-13">

    Noting that there is no class attribute whatsoever. Off the top of my head I don't know what's stopping those attributes from displaying, unless perhaps the core plugin templates themselves have been edited, however the tl;dr is that this plugin won't work unless those classes - in particular cat_your-category - are present.

    With that in mind, you would probably do well to pose the question of why they are missing over on The Events Calendar's support pages:

  18. rockytt
    Member
    Posted 1 year ago #

    I really appreciate your help Barry - haven't made any mods to the calendar plugin, so we'll see what they say over there. Have a great day!

  19. Barry Hughes
    Member
    Plugin Contributor

    Posted 1 year ago #

    No problem. Since I wear two hats it's possible I'll be the one helping you there, but if not I'm sure Jonah, Rob or Leah will be happy to help. Have a great day - hopefully it will be sorted out shortly.

  20. Andy Fragen
    Member
    Plugin Author

    Posted 1 year ago #

    Barry, thanks. rockytt, we'll see you in the other forum.

    I'll close out this thread as it seems the issue not from this plugin.

  21. pigsound
    Member
    Posted 4 months ago #

    hi,
    like rockytt i have the problem that neiter in the list view nor in the widget the category color is displayed. looking at the source code with firebug, i seem to see the div with the opening tag containing the category name. hmmm...
    i deactivated all plugins and changed the theme to check if it makes any difference, but the result is always the same: no colors.
    can you help me, please?
    pigsound

  22. Andy Fragen
    Member
    Plugin Author

    Posted 4 months ago #

    pigsound, this thread has been closed for 10 months. Can you start a new thread? Also, include a URL to the site with the problem. Also, let us know what versions of all plugins you are using. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic