WordPress.org

Ready to get started?Download WordPress

Forums

Colored border around linked image (7 posts)

  1. JasperLensselink
    Member
    Posted 4 years ago #

    While linking an image, the image is shown with a blue or purple border. Aih, it is so ugly! Does anybody know how to get rid of this border or how to change it into white?

    Thanks in advance,

    Jasper Lensselink

  2. extatix
    Member
    Posted 4 years ago #

    Is it the same color as normal links?

  3. alchymyth
    Forum Moderator
    Posted 4 years ago #

    totally depends on your theme's style.css or other applicable css file.

    http://www.w3schools.com/CSS/css_link.asp

  4. JasperLensselink
    Member
    Posted 4 years ago #

    Dear Extatix and Alchymyth,
    THanks for your reponse, but I still cannot sort it out..
    I know how to change it, but do not no where. I can't find any link related issues in my style.css and can't find a link.css either...
    Any ideas?

    Kind regards,

    Jasper

  5. alchymyth
    Forum Moderator
    Posted 4 years ago #

    you are invited to post a link to your site, so that someone might have a look at it and point it out to you.

    link related styles have this a in the style, just as an example:
    .post a { border:1px solid blue;}

    however, if there is no definiton of the link styles in your style.css,
    the browser will decide how to show the link (and that might be different for different browsers) and one of these browser default behaviours is to put a blue line under the link ofr a blue frame around linked images.

    in which case you have to add a new style to your style.css to tell define the way your linked images shall be styled.

    try, for instance, to put this line quite at the beginning of style.css of your theme:
    a img { border:none; }

  6. JasperLensselink
    Member
    Posted 4 years ago #

  7. alchymyth
    Forum Moderator
    Posted 4 years ago #

    there is not a single linked image in the link you posted.
    did you solve your problem?

    or could you point to a post or page that shows this blue border around a linked image.

    in which browser do you get this phenomenon?

Topic Closed

This topic has been closed to new replies.

About this Topic