WordPress.org

Ready to get started?Download WordPress

Forums

Encounters Lite
[resolved] Color Changing (11 posts)

  1. Andyjw
    Member
    Posted 3 months ago #

    Hi, installed theme and activated child theme. Trying to change colors using the theme customising panel. I can change other features ok, eg title, logo, social settings etc, but for some reason any colour changes are not actioned....am I missing something obvious? I'm building my site on localhost using xampp. Should mention I've also tried installing all the plugins listed in your readme.txt file and tried changing colours on both the parent and child theme without success.

  2. StyledThemes
    Member
    Theme Author

    Posted 3 months ago #

    To clarify, when you click on a colour selector, it doesn't open or let you choose colours?

  3. Andyjw
    Member
    Posted 3 months ago #

    No it all appears to work fine, I click on the selector, specify a new colour (either by entering the hex code or clicking on one of the pre-defined colours), click on save&publish but no change happens on my page. I've tried background colours, text colours & border colours but the page stays the same. It may be worth mentioning that above and below the page preview there are numerous repeats of the following error...

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'encounters-lite_sanitize_hex_color' not found or invalid function name in C:\xampp\htdocs\whiteleaf\wp-includes\plugin.php on line 192

  4. StyledThemes
    Member
    Theme Author

    Posted 3 months ago #

    Did you recently update to WP 3.9.1? Also, it sounds like a plugin could be causing a conflict. The customizer is actually a WordPress feature and the theme option settings are simply added to it.

    One way to find out if it's a plugin, is the old fashion method of disabling all plugins, then one by one activate them while testing the customizer after each one is turned on. If it's a plugin, you can find out what one is causing issues.

    It should be noted that WP 3.9.0 caused problems for a lot of people, from widget issues, to the customizer itself. I again tested the theme on my local which I also use XAMPP for development. I was not able to replicate the error, which leads me to believe it's either a bad update of WP, or a plugin is causing conflict with the WP customizer.

  5. Andyjw
    Member
    Posted 3 months ago #

    Ok thanks for that I'll play with the plugins! Yes this is a new 3.9.1 install to build a new site based on your theme. I could modify the CSS to sort the colours but seems such a shame when you have this great customiser to make it easy! Have to say I'm super impressed with the speed you responded to my query. Last theme I used for real I purchased and never got a response from the developers at all!

  6. Andyjw
    Member
    Posted 3 months ago #

    Hmmmm, ok tried disabling all the plugins, then tried modifying the content text and selected the red box #dd3333 clicked on save&publish and no change in the preview window. Refreshed the page and the content text colour as reverted back to the default #787b7f

    Just doesn't want to play ball with me! :(

  7. StyledThemes
    Member
    Theme Author

    Posted 3 months ago #

    I took another look at that error... I think I know what the problem is. Contact me from my website HERE and I will send you a new customizer file to try out.

    UPDATE: Looks like what I assumed is what I discovered...a big oops on my part. I will need to upload a new update for Encounters Lite today with the fix (which works now on my test site).

  8. Andyjw
    Member
    Posted 3 months ago #

    Ok just sent you my contact details through your website. Looking forward to the update, many thanks!

  9. StyledThemes
    Member
    Theme Author

    Posted 3 months ago #

    Got your email...thanks. New theme version sent; let me know how it works out for you. Cheers.

  10. Andyjw
    Member
    Posted 3 months ago #

    Hi Andre, works perfectly, many thanks! Glad it wan't me going mad :)

  11. StyledThemes
    Member
    Theme Author

    Posted 3 months ago #

    No worries...glad it works now for you. As I mentioned, it ended up being my fault...oops!

Reply

You must log in to post.

About this Theme

About this Topic