WordPress.org

Ready to get started?Download WordPress

Forums

WP to Twitter
[resolved] Code : Twitter did not return a recognized response code. (7 posts)

  1. iulianba
    Member
    Posted 7 months ago #

    Hello,

    I know twitter api changed, but I have not made any changes in WP to Twitter options, so I guess I always used https. I always get this message now when posting/updating. Any ideas if I should enable something? I`m on a VPS server.

    Thanks

    http://wordpress.org/plugins/wp-to-twitter/

  2. Joe Dolson
    Member
    Plugin Author

    Posted 7 months ago #

    First, you should verify that you're using HTTPS. It's under the Error Messages & Debugging section of the WP to Twitter settings.

    An unrecognized response code means that your server was unable to reach Twitter at all, so it did not receive a response. This can happen for many reasons, but if you've been able to use WP to Twitter in the past, it may be a temporary situation. If you've made any server changes recently, however, it may be worth reviewing those, in case they broke something related to making remote requests.

  3. iulianba
    Member
    Posted 7 months ago #

    I`m using https. The plugin worked until this morning (10 in the morning, GMT+2).
    I`m not sure what do I need to install (if any) on my server. I read various websites that specified CURL SSL, which I checked in apache config and is installed.

  4. Joe Dolson
    Member
    Plugin Author

    Posted 7 months ago #

    That should be sufficient, but there still could be other reasons - Twitter blocking your server or c-block of IPs, etc.

    Can your server contact other external services, such as the WordPress plug-in API, to install new plug-ins?

  5. iulianba
    Member
    Posted 7 months ago #

    Seems that there was a problem with my server contacting external services. I could not update or install any plugin. Now it`s all back to normal, thanks for the support.

    By the way, as a future feature request: Can you make an option to skip just once (basically this time) the twitter update for a post?

    Thanks

  6. Joe Dolson
    Member
    Plugin Author

    Posted 7 months ago #

    You can already do that - just flip the option to not Tweet the post in the WP to Twitter meta box when you publish.

  7. iulianba
    Member
    Posted 7 months ago #

    I know that, but that option will be checked next time. I manage like 5000 posts and update many of them at a daily basis. 99% of the cases I forgot which one I checked not to tweet and Im too lazy to check the meta box each time. So just a "dont tweet this time" radio button will be really cool.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.