WordPress.org

Ready to get started?Download WordPress

Forums

Code Changes When You Save or Publish (4 posts)

  1. gtaggart
    Member
    Posted 7 years ago #

    Hey,

    I've experienced an occasional problem with code. For example, I've cut and pasted Amazon.com link code into a post in case someone wants to buy a book I'm talking about. Then I save or publish the post, and the code changes subtely, so the link doesn't work as it should.

    It also happens when I embed YouTube code into a post. It always works fine the first time I post, but when I edit the post to fix a misspelling or some punctuation, the code--which I haven't touched or even come close to touching--changes, so the video disappears and all that is left is the empty space with the video was and one of those little "x's" in the upper left hand corner.

    Any idea how to solve this ongoing problem?

  2. Vince2006
    Member
    Posted 7 years ago #

    Are you using IE?

    I had this issue. Try first going to your profile and turning off your rich text editor function. Then re-paste the code and see if this works.

    If it doesn't, watch out for embed tags and object tags. If these are the ones causing the problem, check what version of Java you are using. I had to downgrade to 1.5.0 to stop the error you had from happening on my production pc.

    Hope this helps.

    Vince

  3. gtaggart
    Member
    Posted 7 years ago #

    Yes. If I use Firefox, will that solve the problem? I know Firefox avoids another IE problem, the "Stack overflow in line 1585" problem.

    Thanks for your help. I'll see if it helps.

    Anyone else have a better solution?

  4. moshu
    Member
    Posted 7 years ago #

    The basic rule is: disable, turn off the rich text editor (visual, wysiwyg) if you want to put code in posts.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags