WordPress.org

Ready to get started?Download WordPress

Forums

CMS Tree Page View
CMS Tree Page View and Advanced Custom Fields (11 posts)

  1. cmsme
    Member
    Posted 9 months ago #

    CMS Tree Page View seems to break Advanced Custom Fields. When i install both plugins, the first sub menu item under "Custom Fields" on the left admin menu gets replaced with a broken link titled "Tree View". Not sure which plugin is to blame, but am posting to both support forums. thanks

    Picture of the problem

  2. Per Soderlind
    Member
    Posted 9 months ago #

    Doesn't happen on my site running acf 4.3.0 and CMS Tree Page View 1.2.19

  3. cmsme
    Member
    Posted 9 months ago #

    Still happening for me:

    Vanilla Install, no other plugins:

    WordPress 3.7.1
    CMS Tree Page View 1.2.19
    Advanced Custom Fields 4.3.1

    Earlier versions used to work together, but not any more. I contacted Elliot from Advanced Custom Fields, and he asked if i could contact the dev of CMS Tree Page View to see if they can help with the issue. thanks again!

  4. PadreManson
    Member
    Posted 9 months ago #

    same issue for me. Any response from the Tree Page View support?

  5. Tim Berneman
    Member
    Posted 8 months ago #

    I have the same problem. The "Custom Fields" option on "Advanced Custom Fields" turns to "Tree View" with a link to "/wp-admin/cms-tpv-page-acf" which is broken. I deactivate "Tree View" and "Advanced Custom Fields" is back to normal with the correct link of "/wp-admin/edit.php?post_type=acf".

    I will leave "Tree View" deactivated until it's fixed.

    WP v3.7.1
    TV v1.2.19
    ACF v4.3.1

  6. esmi
    Forum Moderator
    Posted 8 months ago #

    @cmsme, @PadreManson & @Tim Berneman: If you require assistance then, as per the Forum Welcome, please post your own topics.

  7. Tim Berneman
    Member
    Posted 8 months ago #

    Sorry. Since it was the same problem with the same plugins I just wanted to add to the topic so the plugin author had more information to diagnose the issue and create a fix for it. I know as a plugin author myself I appreciate any and all facts to help me figure out the problem. It didn't seem like I should start another topic with the same problem. Again, my apologies.

  8. cmsme
    Member
    Posted 8 months ago #

    Any chance the plugin developer could chime in here? thanks

  9. chris@vendiadvertising.com
    Member
    Posted 8 months ago #

    I can reproduce it on several sites, too. The solution that works for me is to go to Settings, CMS Tree Page View and uncheck everything for "Field Groups"

  10. Pär Thernström
    Member
    Plugin Author

    Posted 8 months ago #

    Thanks for the fix @chris. Also thanks to all others for reporting this. I don't use Advanced Custom Fields myself since I use my own plugin Simple Fields.

    Anyway, I will try to look into this soon. If any other would like to make a fix please feel free to post a pull request over at github:
    https://github.com/bonny/WordPress-CMS-Tree-Page-View

  11. Pär Thernström
    Member
    Plugin Author

    Posted 6 months ago #

    Can you check if the latest update of CMS Tree Page View solved this?
    http://wordpress.org/plugins/cms-tree-page-view/changelog/

Reply

You must log in to post.

About this Plugin

About this Topic