WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] CMS change urls without changing core file location (14 posts)

  1. julier
    Member
    Posted 4 years ago #

    I am a WordPress novice using it as a CMS with no blog at all. I have it installed on a hosting server in a subdirectory - http://www.mydomain.com/wp. I've updated to 2.81 and everything works - customized theme, permalinks, widgets, plugins (nextgen gallery), images, etc are all great. Now I want the static home page with navigation, widgets, etc to show up as if they are in the root directory http://www.mydomain.com but I want to keep the entire wordpress core files installation in the /wp directory. Can this be done and if so, how (preferably without breaking everything.)?
    My apologies if this request is not clear.

  2. You can give your WordPress its own directory like you mention and details on how to make it show up on your domain can be found here:

    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

  3. julier
    Member
    Posted 4 years ago #

    Those details seem to apply to when wordpress is not already in the directory you want it in. My wordpress is in the correct directory. WordPress is installed in mydomain.com/wp where I want it. I want the home page to be in the root directory at mydomain.com. I have gone through the codex and forums and I know I can change the url of the blog (home page) address to the root directory. I need to know what else I would have to do (and in what order) to make it all (especially images, plugins, galleries) work correctly when I am NOT moving wordpress,

  4. You don't have to do anything else, but to make the changes described at http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    You don't have to move your wordpress or do any special to images, plugins, galleries. When you are ready to go live, just follow the steps described in the codex and your site will appear at YOURDOMAIN.COM, and your wordpress will stay at YOURDOMAIN.COM/WP/

  5. julier
    Member
    Posted 4 years ago #

    Thanks a bunch! I thought having step 6 done first might be a problem.

  6. sarthaksinghal
    Member
    Posted 4 years ago #

    I have my files at /blog and the blog should also appear at http://www.website.com/blog. But the homepage at http://www.website.com should also be powered by wordpress.

    How can i do this? Thanks in advance

  7. Hello Sarthak

    In your admin, under reading, select the second radio button - Front page displays a static page.

    Choose the page that you want as your home page

    I usually create a page call blog and select that page as the one to show my posts on.

    Then also follow the directions above on how to give WP it's own directory.

  8. sarthaksinghal
    Member
    Posted 4 years ago #

    Thanks Christine,
    Following are my operations:
    In Setting->General the WordPress and Blog URL are mentioned as http://www.website.com/blog.

    I created 2 static pages, home and blog. The slug for them is http://www.website.com/blog/home and http://www.website.com/blog/blog. Can yo explain me why is this happening?

    I want the home page to be situated at http://www.website.com and blog page at http://www.website.com/blog.

    In the static page blog, how can ensure it lists all the posts as I already have many posts under the blog.

    ..Sarthak

  9. Hello Sarthak,

    I think that you need to make a minor tweak to your settings.

    General Settings:
    WordPress address (URL) ---http://www.website.com/blog (this shouldn't change and DON'T change it... otherwise it will mess things up royally)

    Blog address (URL) --- http://www.website.com/

    Once you've set your blog url as the root of for your site, then you should have the pages and slugs displaying properly.

    I think that the error here is that the blog address is a bit misleading. Your blog in this instance is the entire site and not just the blog section.

  10. sarthaksinghal
    Member
    Posted 4 years ago #

    Hi again Christine,

    I changed the blog address to http://www.website.com/
    The static pages are still configured.

    Now when I goto http://www.website.com/blog, I get the following error "Firefox has detected that the server is redirecting the request for this address in a way that will never complete."

    Any clues?

  11. That's very strange.. I've never seen this happened before. I did a google search and found this:

    http://support.mozilla.com/tiki-view_forum_thread.php?locale=en-US&comments_parentId=5104&forumId=1

    Looks like clearing your cache may be needed.

  12. sarthaksinghal
    Member
    Posted 4 years ago #

    Thanks for the link. I tried the solutions provided in that link and still face the same issue.

  13. sarthaksinghal
    Member
    Posted 4 years ago #

    I think I will have to move to a new CMS system, as my requirement is not just of a home page. I need many other virtual directory structures apart from just /blog.

    Thanks for your help.

  14. keithmcmean
    Member
    Posted 4 years ago #

    Not sure if this is the right place to ask this but i need a way to change my file structures quickly. I have my client sites on a subdomain http://clients.mysite.com/client1/ and when I move the site to the live site http://www.myothersite.com all the links etc keep the subdomain references, is there a quick way to change this?

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Topic