WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
CloudFlare API error (31 posts)

  1. ogalinski
    Member
    Posted 1 year ago #

    I'm getting this error:

    "Unable to communicate with CloudFlare API: Setting: zone_settings Invalid token or email."

    I don't seem to find the error. Any ideas?

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    This issue is occurring with the latest release?

  3. ogalinski
    Member
    Posted 1 year ago #

    Yes.

  4. sLa NGjI's
    Member
    Posted 1 year ago #

    I have same problem.

    I have disable W3 Total Cache 0.9.2.6 CloudFlare Support and activate Official CloudFlare Plugin.

    Problem Solved!

  5. ogalinski
    Member
    Posted 1 year ago #

    I've managed to iron all the wrinkles. The error I mentioned first (the CloudFlare API) is the last one I'm experiencing. Any ideas?

  6. healthable
    Member
    Posted 1 year ago #

    Since i upgraded to the lastest release everything is BROKEN. My site now uses 2 themes and when i try to save my cloudflare settings i get 404 error

  7. crownabhisek
    Member
    Posted 1 year ago #

    i'm also experiencing the same problem

  8. Pascal Dreissen
    Member
    Posted 1 year ago #

    Please make sure you are using the e-mail address under the account settings of cloudflare in W3TC, had the same problem because before you needed to use the user name instead! That fixed above error for me!

  9. CoolRunLT
    Member
    Posted 1 year ago #

    Having the same problem here with the latest release. Noticed a huge decrease in Y-Slow score (A to E). Not sure how to fix this one yet - my e-mail and setting in Cloud Flare are all 100% right.

    Anyone find a way to make this work yet?

  10. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    I believe this is fixed in 0.9.2.7, sorry for the trouble.

  11. jp1222
    Member
    Posted 1 year ago #

    I downloaded 0.9.2.7 today and having this issue. I enter in my API key, it gives me the message that it is connected, then within a few hours, I get the "Unable to communicate..." error.

  12. beernews
    Member
    Posted 1 year ago #

    Downloaded 0.9.2.8 this morning. Enabled Cloudflare with correct settings & got this error:

    Unable to communicate with CloudFlare API: Setting: minify Invalid token or email.

  13. beernews
    Member
    Posted 1 year ago #

    Nevermind. I was testing something before and had Cloudflare 'paused' for that domain & forgot to turn it back on. Fixed.

  14. jp1222
    Member
    Posted 1 year ago #

    I downloaded 0.9.2.8 and am still getting the unable to communicate error. It will tell me it is connected when I initially save it, but if I leave the General Settings page and go back, then it gives me the unable to communicate error.

  15. Erwan
    Member
    Posted 1 year ago #

    Hi,

    Same problem here, if I read well (I'm a newbie with CloudFlare).

    Everything looked wonderful (amazing load time decrease of my "little" self shared hosted WP blog... 99% sure it's thanks to CloudFlare!), until now :

    1. Performance decrease,
    2. Cloudfare plugin alone : no error displayed
    3. Last W3TC update (0.9.2.8) alone : "Unable to communicate with CloudFlare API: Setting: async The requested domain does not exist or is no longer active." [with correct e-mail & correct API of course].

    Help, totally lost now :) !

  16. roadrashtx
    Member
    Posted 1 year ago #

    I ran into the same issue with 0.9.2.8. I checked the settings for Cloudflare in W3 Total Cache and it looked correct.

    I also tested by replacing the API and that did not work. It was not until I typed my email address in again (even though it was already showing correctly) that it then worked and I did not get the error any longer.

  17. 1energy1
    Member
    Posted 1 year ago #

    WordPress 3.5.1
    W3TC 0.9.2.8 alone ==> "Unable to communicate with CloudFlare API
    tried several times to save settings, regenerated API key
    was working ok with exactly same settings, didn't change nothing

  18. 1energy1
    Member
    Posted 1 year ago #

    using WP Super Cache and CloudFlare plugin works ok, without "Unable to communicate with CloudFlare API", but only got Page Speed 87% (B) while 95% (A) with W3TC, we need 0.9.2.9 with a fix.

  19. CoolRunLT
    Member
    Posted 1 year ago #

    The new update was actually breaking my theme (making it show up bad in Firefox). I deactivated this plugin since it was doing it, and my Yslow score actually went up and my site works great now. I miss the original W3TC before this past update :-/

  20. Erwan
    Member
    Posted 1 year ago #

    I tried & tried again (re-typed e-mail, regenerated API key, saved different settings,...) : no way, still have "Unable to communicate with CloudFlare API: Setting: zone_settings Invalid token or email." with W3TC 0.9.2.8 alone.

  21. sLa NGjI's
    Member
    Posted 1 year ago #

    Is possible that CloudFlare dropped support to W3 Total Cache for this irriverent and not elegant message that appears on WordPress Dashboard after W3 total Cache / CloudFlare configuration:

    CloudFlare plugin detected. We recommend removing the plugin as it offers no additional capabilities when W3 Total Cache is installed. This message will disappear when CloudFlare is removed.

    Is Really Possible? :)-

  22. 1energy1
    Member
    Posted 1 year ago #

    When you are using W3TC you don't need the Cloudflare plugin because W3TC have Cloudflare functionality inside, so you can remove that plugin to free resources, but you still using Cloudflare and W3TC recommends it, so Cloudflare should not be angry. :)

  23. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    It's not essential to remove the Cloudflare plugin, it's just important that you try not to change settings in both places. Using either plugin to change settings or report spam is fine.

  24. Wisdomkid
    Member
    Posted 1 year ago #

    Wow, i'm also getting this problem with a blog of mine, this same issue is same while using the cloud flare plugin with this w3t plugin, what's wrong?

    dailyjobvacancy.com

    what's wrong?

  25. SuperTamagochi
    Member
    Posted 1 year ago #

    Hi

    I actually have the issue, Is there any solution??

    Best Regards

  26. dennisjpitocco
    Member
    Posted 1 year ago #

    Same issue here - taken all the possible steps above, but the message prevails:

    "Unable to communicate with CloudFlare API: Setting: zone_settings Invalid token or email."

    Any ideas appreciated!

  27. Jcast
    Member
    Posted 1 year ago #

    I am also getting this problem.

  28. dyland
    Member
    Posted 11 months ago #

    I had this issue, fixed it by updating the account email address and Cloudflare API Key field.

  29. tgdtgd
    Member
    Posted 11 months ago #

    Hi, has anyone got an answer for this? I was getting this message...

    "CloudFlare plugin detected. We recommend removing the plugin as it offers no additional capabilities when W3 Total Cache is installed. This message will disappear when CloudFlare is removed."

    ...so I deactivated the CloudFlare plugin. I then immediately got the "Unable to communicate with CloudFlare API: Setting: minify Unknown token or email" message.

    I reactivated the supposedly unneccessary CloudFlare plugin to see if the message would go away. Which now leaves me with both messages and no idea what's going on!

    Can I ignore the "Unable to communicate...." message, or does it mean there is indeed something wrong with my CloudFlare set-up?

    Any help would be much appreciated. Thanks!

  30. dfumagalli
    Member
    Posted 11 months ago #

    @tgdtgd

    There are cases of the error coming up but the setup still working fine but also cases when the setup is really broken.

    To see which of the two you are experiencing:

    1) Run a Page Speed and YSlow test.

    2) Now go to your Cloudflare panel, click the "Gear shaped" button all to the right of the relevant website of yours. Select "Pause Cloudflare".

    There are other ways (like using direct.your domain.com etc.) but this one is the easiest.

    3) Repeat the tests. If they are worse, then you are just experiencing a message display issue. If they are the same, your setup is not working. You might try and create a new Cloudflare API key and enter that in W3 TC but there may be adverse consequences on your other websites at doing that. You'll have to put that API in each of them and some might stop working.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic