WordPress.org

Ready to get started?Download WordPress

Forums

Closing tags get deleted and ignored (3 posts)

  1. chidade
    Member
    Posted 8 years ago #

    Firstly, I should point out that I haven't upgraded anything, nothing has changed in my setup since I first got it going, and this is the first time that the problem has appeared.

    The code looks like this:

    ...armed myself with her <strong>Octopus</strong> card (like the <strong>Suica</strong> card but works on <strong><em>every possible kind of transportation</em></strong> - even the tram that runs up to The Peak) and set....

    But when I save it or preview it, the first </strong> disappears and the rest of the blog is in bold. I thought it was a mistake at first so I re-entered the closing tag and tried again, but no, same problem. So I decided to remove the strong tags around that word and tried again. But then the </strong> after the word 'Suica' disappeared and the rest of the blog was bold again. Removed that set of strong tags and the same problem was there! I removed all the strong tags then the same problem happened with the </em> tags.

    Why is it doing this? I though I might've click the Close Tags quicktag by accident, but I can't find the missing tags anywhere else in the post. Also, all the tags work fine before and after this paragraph. I even tried copying and pasting my work into a new post but the problem remains.

    Can someone help, please?

  2. chidade
    Member
    Posted 8 years ago #

    After upgrading to 2.0.1 i still have the same problem. Can someone reply please? Do you want screenshots?

  3. dkusleika
    Member
    Posted 8 years ago #

    chidade: I unchecked "WordPress should correct invalidly nested XHTML automatically" under Options - Writing, and it took care of this exact problem for me. However, once I did that (knowing it was just hiding the problem) I investigated my post a little closer. I had a less than sign above where the problem was happening. WP interpreted that as a tag, of course, which confused the heck out of it. I changed the less than sign to & l t ; without the spaces, rechecked the Option and everything worked fine.

Topic Closed

This topic has been closed to new replies.

About this Topic