WordPress.org

Ready to get started?Download WordPress

Forums

clients and auto-formatting (13 posts)

  1. ryanoz
    Member
    Posted 6 years ago #

    URRRRUUUGHHHHGGGGHGH!
    so I have a site set up for a client, its all pages.
    I have visual styling turned off while I'm working on the site, but it needs to be on for them as a 'editor' user. Problem is, when they use the visual editor it is striping out content. Specifically, I have a <flv href="blah.flv"> on the page. But if they login to change something on the page thru the visual editor... it strips out the FLV!! How can I keep this from happening? Please help! Thanks.

  2. ryanoz
    Member
    Posted 6 years ago #

    I know its a common issue and I'm looking thru this forum for a solution. I'll even take search recommendations. "auto formatting" returns a lot of results, i'll just have to go thru them all. I guess what I really just need to find out is if there is anyway to have <flv> not stripped out when switching to visual editor.

  3. ryanoz
    Member
    Posted 6 years ago #

    nothing? well, i've search the whole forum. There are several ways to turn auto-formatting off, but I haven't seen a way to use the visual editor and NOT have auto-format on save. I installed TinyMCE Advanced, but it was buggy as hell; at least in firefox/mac and wasn't even saving the changes I made. So there is no way to modify anything to say... if you see a <flv LEAVE IT ALONE!! ?

  4. ryanoz
    Member
    Posted 6 years ago #

    ok screw it. only way this is going to work then is if I turn off the visual editor for the client! and hope they don't fuq anything up.

  5. boober
    Member
    Posted 6 years ago #

    what kind of page is it that they have to keep going back to for editing? maybe theres a better way to set it up.

  6. ryanoz
    Member
    Posted 6 years ago #

    its not just one page. Its a site with about 7 pages. I've set it up so they can make changes to all the pages. The only issue is with the <flv> tags. I don't understand why when you use the visual editor it strips the flv out, I mean wp-flv is an included plugin in the WP package right?

  7. whooami
    Member
    Posted 6 years ago #

    mean wp-flv is an included plugin in the WP package right?

    uh no.

  8. ryanoz
    Member
    Posted 6 years ago #

    yea. I must have installed a while back and forgot, I thought it was in the new version for some reason. Still rips it out of the page though.

  9. ryanoz
    Member
    Posted 6 years ago #

    really? just can't do it at all huh?
    where is that <don't_auto_format_this_stuff> tag?

  10. mrkingid
    Member
    Posted 6 years ago #

    Use this plugin. It'll save ya.

    http://dev.wp-plugins.org/wiki/TextControl

    or here

    http://wordpress.org/extend/plugins/text-control/

    For the Posts and Excerpts settings use: "Default (wpautop)" in the first pull down & "No character encoding" in the next pull down.

    That should do it.

  11. ryanoz
    Member
    Posted 6 years ago #

    no. I'm dealing with PAGES, and the problem is when switching from "HTML" to "VISUAL"... when switching to "VISUAL" its taking out the <flv>

  12. ryanoz
    Member
    Posted 6 years ago #

    well I figured it out. I don't know why I thought WP-FLV was included in wordpress, I guess I installed in a previous version or something and just saw it there; oh well. Anyway, I noticed a lot of the plugins will use [blahblah stuff="blah"] for inserting into post and pages without the visual editor removing it. So the last couple comments on the website for the wp-flv plugin explains how to make the plugin use [ instead of < and so its good now, visual editor doesn't remove it.

  13. mrkingid
    Member
    Posted 6 years ago #

    quote ::no. I'm dealing with PAGES, and the problem is when switching from "HTML" to "VISUAL"... when switching to "VISUAL" its taking out the <flv>

    Umm, it works for pages too.

    Glad you got it working.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.