WordPress.org

Ready to get started?Download WordPress

Forums

Force Strong Passwords
[resolved] Client-side strength indicator not accurate (5 posts)

  1. jorgeorpinel
    Member
    Posted 4 months ago #

    scrambleheadarsenalmary is indicated as "weak" or sometimes "medium" by the js script but the server accepts it. Am I doing something wrong?

    https://wordpress.org/plugins/force-strong-passwords/

  2. jorgeorpinel
    Member
    Posted 4 months ago #

    Actually this seems to be a issue with roles. When the user is super admin the strong pw is enforced, but when I remove that (from the network users edit page) I can set any pw even if weak.

    Now I'm not sure that the right capabilities are being checked for the users I'm editing, they still have access to certain sites as admins. Is this plugin network compatible?

  3. jorgeorpinel
    Member
    Posted 4 months ago #

    Indeed. It seems this plugin works for the current user (signed in, i.e. me) and from the local site's user edit page, but NOT from wp-admin/network/user-edit.php

    Cheers.

  4. Steve Taylor
    Member
    Plugin Author

    Posted 4 months ago #

  5. jorgeorpinel
    Member
    Posted 4 months ago #

    You know what coming to think of it the title on this topic is misleading, the strength indicator seems to be correct.

    It is the server-side that isn't responding how I would expect and yes it is the same issue as in your github issue tracking.

    So since this title is misleading and the issue is already tracked on github I'll resolve this topic.

    Thanks for the reply.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.