WordPress.org

Ready to get started?Download WordPress

Forums

Clicking 'Update Page' results in a 404 (13 posts)

  1. ratjetoe
    Member
    Posted 4 years ago #

    Hi there!

    I've created a (static) page, and published it.
    Now, when I edit it, and click 'Update Page', I get a 404-error-page.
    It's not a big problem, because it did update: when I go to the blogpage, it shows me the updated page, but it's inconvenient.
    And also, I'm trying this out for someone, and I think this someone would panic over such a problem!

    Can anyone help me?

    Laura

  2. kremlin
    Member
    Posted 4 years ago #

    I have the same problem :-(

  3. stackers
    Member
    Posted 4 years ago #

    Hi

    I'm getting this problem also - exactly the same effect where the update commits but I get redirected to the 404 page or home page depending on how my permalinks are set up. I'm also in the same boat - I can live with it but the guys who will use it may freak out.

    I've scoured through the other forum posts similar to this - I've messed around with .htaccess as suggested and no joy e.g.

    <ifmodule mod_security.c>
    SecFilterEngine Off
    SecFilterPost Off
    </ifmodule>

    I'm using http://www.eukhost.com for hosting - I've seen eukhost mentioned in other posts with similar issues.

    Cheers
    Stef

  4. stackers
    Member
    Posted 4 years ago #

    'Fixed' it by commenting out the following line in wp-admin\page.php and wp-admin\post.php as shown:
    /*'_wp_original_http_referer' => urlencode( stripslashes( $_POST['_wp_original_http_referer'] ) ),*/

    Not seen any adverse effects yet...

  5. option8
    Member
    Posted 4 years ago #

    @stackers - any explanation as to what that's doing/not doing that "fixed" the problem?

  6. option8
    Member
    Posted 4 years ago #

    based on one of several other posts along these lines, i was able to fix the problem. it's related to mod_security, and, at least on my server, the fix was to add this to a .htaccess file inside the wp-admin directory:

    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>

  7. stackers
    Member
    Posted 4 years ago #

    Hi

    The problem was any time that the _wp_original_http_referer parameter was in a URL I was getting a 404. I think the only time I was getting this was when hitting update on a page or post. I don't know enough about apache security or my host's set up to say why. I tried the SecFilterInheritance thing in .htaccess but that didn't work.

    Hacking out the line in post.php prevents the route cause of the problem i.e. when the post.php is cooking up the redirect URL after I hit update post, it no longer includes _wp_original_http_referer and hence no more 404 error.

    Still no adverse problems so I'm quite happy. I'll keep an eye out for a proper solution but I've seen so many posts on this issue and none of the other solutions worked for me.

  8. ratjetoe
    Member
    Posted 4 years ago #

    I guess it's not a problem anymore, probably there is a new version now!
    Thank you everyone!
    Laura

  9. freewheelinotter
    Member
    Posted 4 years ago #

    I currently have this problem after my host went down for a few hours, everything seems to be fine again except when editing pages.

    I tried the fix that Option8 suggested and that didn't do anything to it whereas the line to comment out which stakers suggested doesn't appear to be in my page.php file..

  10. Joshua David Nelson
    Member
    Posted 4 years ago #

    I have the most up-to-date version and I am having this issue. I cannot find the line in the post/page code that you are referring to (@stackers) either.

    Has there been any real fix to this problem? It only appears when I try to edit a page, I hit "Update Page" and it goes to 404.

    I didn't have this problem until recently, but I have not done anything new (no new plugins or updates) that might have cause it. The .htaccess fix doesn't work and I have tried re-upgrading, turning off the plugins, and using a backup.

    Suggestions?

  11. davidricardo
    Member
    Posted 4 years ago #

    OK, I'm having the same issue, though it only happens for certain posts. I can't see any commonalities among the few posts that lead to a 404 upon hitting "Update."

    Did you ever find a resolution, joshuadnelson? I'm pretty sure this problem didn't exist until my host moved us to a different server, but I have no idea how to resolve the problem.

  12. CaptainBlue
    Member
    Posted 4 years ago #

    I am seeing this on updates to pages and posts and new posts.

  13. Joshua David Nelson
    Member
    Posted 4 years ago #

    I am seeing this in every blog I run now. It seems more likely to occur in posts/pages where I paste in content. There is some sort of bug with the saving draft function as well.

    Hello! IS ANYONE out there able to answer this questions?! I've had two forum questions up regarding this without ANY constructive response fotr over 2 months!!

Topic Closed

This topic has been closed to new replies.

About this Topic