WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Clicking on post gives 404 error (7 posts)

  1. baal666
    Member
    Posted 5 years ago #

    Hi,

    Just found something weird on my new blog. I installed it and everything seemed to work perfectly. I wrote a test post and from the admin panel everything looked just normal.

    But guess what, from the index when you click on the title of the post, it gives a 404 error. I checked again in the admin panel and the permalink was good, but still a 404 error when clicking on it.

    Any idea what can cause this problem?

    Thanks

    p.s. Preview gives a 404 as well...

    Site is http://outofyourcage.com

  2. Samuel B
    moderator
    Posted 5 years ago #

    your archives page is weird, too
    http://www.outofyourcage.com/2009/03

    I would try deleting .htaccess and regenerate the permalinks

  3. baal666
    Member
    Posted 5 years ago #

    That was an old plugin (not yet installed) that caused the problem. Now archive is working correctly.

    Hmm... Could this be the problem? I used the same template as on my other blog.

    I deleted .htaccess in my root folder and in my wordpress folder and resaved the permalink options. Didn't work.

  4. baal666
    Member
    Posted 5 years ago #

    Huh-hmmm... Here is what I found:

    http://www.outofyourcage.com/uncategorized/leads-to-404

    is not working

    but

    http://www.outofyourcage.com/uncategorized/leads-to-404%20/

    is working... Must be a space somewhere... I need to find it.

  5. baal666
    Member
    Posted 5 years ago #

    Oh man that was stupid... When I changed permalink, I let a space at the end of the damn thing and there was no way to see it. LOL! Now it works! :)

    Sorry for the trouble and thanks for your help!

  6. morestar
    Member
    Posted 4 years ago #

    same problem happening here...

    what do you mean when you say "I let a space at the end of the damn thing and there was no way to see it"?

  7. morestar
    Member
    Posted 4 years ago #

    I just went into permalinks and checked to see if you were talking about a space after whatever Custom Structure I chose. Well, I have /%postname%/ as my selection, everything worked until a moment ago, either way, i simply "saved changes" with the same /%postname%/ in the box and checked, the 404s were gone.

Topic Closed

This topic has been closed to new replies.

About this Topic