WordPress.org

Ready to get started?Download WordPress

Forums

WP eCommerce
Clicking on buy button brings the user back to checkout page (10 posts)

  1. GretarMagg
    Member
    Posted 9 months ago #

    Hello

    I have version 3.8.12.1 installed and the latest WP version. I have imported some 9.100 coupons into the system and everything is working smoothly with them. I have epub files on some ebook products that the user can download using a coupon code (100% discount). When the user has selected his item in the shopping basket and inserted the coupon and filled out all info about himself he clicks the Buy button but gets redirected to the first step of checkout (i.e. the coupon insertion page).

    What the hell can be wrong here ?

    http://wordpress.org/plugins/wp-e-commerce/

  2. vark
    Member
    Posted 9 months ago #

    Hi,
    really can't help without a URL ...

  3. nurenu
    Member
    Posted 8 months ago #

    This is happening with my store as well. No transactions can go through. User hits purchased and it just goes back to top of the page. I reverted back to WP 3.6.1 and its still doing it
    http://turqsport.com although i may have to put up an under construction block

  4. vark
    Member
    Posted 8 months ago #

  5. nurenu
    Member
    Posted 8 months ago #

    Thanks Varktech. I was thinking its something with too many scripts being called so i was trying to configure BWP-minify and now WP Total Cache but auto minify is too much and breaks things too. ackkkk.

  6. nurenu
    Member
    Posted 8 months ago #

    hmm minified a bit but i dont think this is helping anything. any insight on how i can fix?

  7. nurenu
    Member
    Posted 8 months ago #

    determined that people had to be logged in or it would fail. now i need to figure out guest check out

  8. GretarMagg
    Member
    Posted 8 months ago #

    Sorry varktech.com, can you email me at gretar@endor.is because I need to give you access to the site as it is not open yet. The URL is http://www.bokabeitan.is and I have a plugin that displays a message that says we are working on a new site.

  9. vark
    Member
    Posted 8 months ago #

    @GretarMagg
    The place to start is in Chrome or Firefox with Firebug, and checking for JS errors...

    @GretarMagg & @nurenu
    Assuming that the problem may be a conflict, a help would be to use the deactivate dance -
    deactivate all plugins but wpec, switch to the 2012 theme, test. If clear, add 1 plugin or the theme, retest. Rinse and repeat until you've identified the errant module.

  10. GretarMagg
    Member
    Posted 8 months ago #

    For now I think everything is working now, no changes have been made though so I'm not sure what was wrong in the first place.... But here's hoping everything is running smoothly now.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.