WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Clicking on a dates archive redirects to homepage (7 posts)

  1. MAK
    Member
    Posted 4 years ago #

    Hi.

    I'm puzzled about something. All of a sudden now anytime I click on an archive link doing so redirects to the home page for no reason I am aware of.

    For example clicking September 2009 link redirects to the Homepage.

    I do not have any redirects in my .htaccess file so I'm confused as to why this no longer works as it should. I do have an archives page and it used to work but now it doesn't.

    Here is a link and if you are willing to help, try it yourself from the tabbed widget in the side bar .

    http://makaz.kicks-ass.net/blog/

    Thanks

  2. MichaelH
    Member
    Posted 4 years ago #

    With the help of the Template Hierarchy article, determine what Template is displaying your archives.

    Maybe your archive template got deleted (or is corrupt?).

    You don't have any conflicting plugins do you?

  3. MAK
    Member
    Posted 4 years ago #

    Nah,

    I do have an archives.php and I have done nothing to it in a long while now so as far as I am concerned it should work like normal.

    I have the standard template files, index.php, page.php archives.php and so forth.

    As you may have seen on the webpage I am using a tabbed widget box but this redirect problem occurred even before I ever installed it.

    As to your last question, what sort of plugins would even interfere with the link process?

    Oh also. I need to point out that doing searches from the default search box also doesn't work. When you try to search for something on the site it also redirects to the homepage as well.

    EDIT: Apparently it is a plugin interfering.

  4. MAK
    Member
    Posted 4 years ago #

    For those who may have this issue also:

    If you try to do searches using your default search box and doing so redirects to your homepage with no search being performed

    or

    When you click on an archive link and it redirects to your homepage without showing the archive content

    If you happen to have the Robots Meta plugin by Yoast, this is the culprit causing the problem.

    Here is the section of the Robots Meta plugin causing the problem: Uncheck the three BOLD settings to fix this.

    Disable the author archives

    If you're running a one author blog, the author archive will always look exactly the same as your homepage. And even though you may not link to it, others might, to do you harm. Disabling them here will make sure any link to those archives will be 301 redirected to the blog homepage.

    Disable the date-based archives

    For the date based archives, the same applies: they probably look a lot like your homepage, and could thus be seen as duplicate content.

    Redirect search results pages when referrer is external

    Redirect people coming to a search page on your site from elsewhere to your homepage, prevents people from linking to search results on your site.

    NOTE: I have no idea why these three settings would cause the two problems I mentioned. The description for the settings mentions it's to block people outside of your website from linking to these search pages - I understand that part but why it actually prevents you from doing searches within the site itself or clicking on archive links from within the site itself I have no clue.

    But anyhow I disabled these three settings and I'm back to normal with links and searches working.

  5. schoe
    Member
    Posted 4 years ago #

    Hi MAK,

    for two days I was checking all my additional actions and filters trying to solve this "homepage problem" ... and I really was at my wits' end...

    Your last message saved me... thank you very much!!!

    I didn't find the time to check the source yet and I'm afraid there are some other feature problems with the Robots Meta plugin in the "Prevent Indexing" section which I want to check first...

    Would you post again please if you get a clue!

    schoe

  6. MAK
    Member
    Posted 4 years ago #

    Hi schoe,

    I am not sure what you are asking of me when you said, "Would you post again please if you get a clue!"

    Anyways, the only other problem I have encountered with the Robots Meta plugin is that it prevents me from using Windows Live Writer; it prevents posts being uploaded to my blog when the plugin is activated. This is the error message I get when it's installed:

    http://www.flickr.com/photos/16731818@N00/3964174354/sizes/o/

    Another plugin that causes this same problem for me is the Bad Behavior plugin. So anytime I want to use Windows Live Writer I have to disable both of those plugins first, make my posts, then reactivate them.

    I have since stopped using Bad Behavior because it was causing problems in my sidebar when I was trying to use another addon. Bad Behavior behaves badly with several addons, so instead of using Askimet + Bad Behavior I am using Askimet + reCAPCHA instead.

    Oh well, sorry I got off-topic.

  7. sarthaksinghal
    Member
    Posted 4 years ago #

    Thanks. It did the trick for me.
    After disabling the options, i was able to get the search and archive links to work for me.

    The help here was very helpful.

Topic Closed

This topic has been closed to new replies.

About this Topic