WordPress.org

Ready to get started?Download WordPress

Forums

Clicked Post tranfer to Whoops! Whatever you are looking for cannot be found. (4 posts)

  1. RooftopRunners
    Member
    Posted 3 years ago #

    Hello,

    I use to be able to click my posts. Directed to a place where I could comment.
    Now when I click the post I am directing to WHOOPS! whatever you are looking for cannot be found.

    My website is http://www.rooftoprunners.com

    Any help would be much appreciated.
    Thank you,
    Tobias

  2. Lisa Sabin-Wilson
    Member
    Posted 2 years ago #

    Your permalinks are wonky - for instance, your most recent post is pointing to: http://www.rooftoprunners.com/http:/www.rooftoprunners.com/topics/blog

    See how the domain is repeated there?

    To fix your permalinks, go to:
    Dashboard --> Settings --> Permalinks

    Select "Day and name" then click Save Changes.

    That *should* fix your htaccess file and your permalinks, as long as your .htaccess is writable by WordPress. If not - connect to your web server via FTP and edit the .htaccess file to make sure they include the following re-write rules:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Hope that helps.

  3. rfair404
    Member
    Posted 2 years ago #

    BEFORE YOU READ ANY MORE OF THIS POST BACKUP YOUR DB AND FILES!

    First of all read the first line again, don't skip it.

    I think that you have done one of two things wrong:

    your permalink s include the site url somehow or your site url is set wrong.

    Look CAREFULLY at a link that I grabbed from your site:

    http://www.rooftoprunners.com/http:/www.rooftoprunners.com/topics/blog/uncategorized

    notice that the second http is written http:/ with just one slash. you need to get that fixed first.

    Reset your permalinks to the default, then go to settings general and be sure that the site url and home are set correctly.

    If this does not work, delete your .htaccess file from your site (just remane it to htaccess.txt and then reset your permalinks again, this will allow WordPress to re-create it.

    If that does not work, check out this script: http://interconnectit.com/124/search-and-replace-for-wordpress-databases/

    search for http:/www.rooftoprunners.com and replace with http://www.rooftoprunners.com

    Good luck.

  4. RooftopRunners
    Member
    Posted 2 years ago #

    Thanks you so much for your help and taking the time to figure out the problem. I am truly grateful.
    Cheers,
    Tobias
    ps. Feel free to check out our music

Topic Closed

This topic has been closed to new replies.

About this Topic