WordPress.org

Ready to get started?Download WordPress

Forums

Google XML Sitemaps
click 'Setting' displays 'internal server error' error message (7 posts)

  1. hiddai
    Member
    Posted 1 month ago #

    1. WordPress and plugin Versions: 3.9.1 and 4.0.7
    2. Blog URL Address: http://yahwade.azurewebsites.net
    3. I don't know the software of my webserver. It's not Apache and there are IIS files there in the WWWROOT.
    4. Additional plugin: Aksimet.

    Scenario:
    1. I install the plug-in
    2. then click setting

    the results were:
    1.http://yahwade.azurewebsites.net/wp-admin/options-general.php?page=google-sitemap-generator/sitemap.php page was opened.
    2. "The page cannot be displayed because an internal server error has occurred." was displayed.
    3. click on General>XML-Sitemap give the same error message.

    Please your help activating the setting page in order to use the plug-in and create a Sitemap file.

    thanks

    Hiddai

  2. arnee
    Member
    Plugin Author

    Posted 4 weeks ago #

    Hi,

    you you access to the error log of the web server?

  3. hiddai
    Member
    Posted 3 weeks ago #

    Yes.
    1. I clear the logs.
    2. navigate to: "http://yahwade.azurewebsites.net/wp-admin/options-general.php?page=google-sitemap-generator/sitemap.php" and get the 'internal server error'
    3. opened the log file in my server and saw the following message:
    "The specified resource does not exist. RequestId:d1e65075-99f3-4586-9184-9303c15907f1 Time:2014-06-28T19:41:30.5067455Z"
    4. To mention that i have the file: sitemap.php. Is this a permission problem?

    If this message doesn't help, please guide me - what do you need exactly.

    thanks,

    Hiddai

  4. utahman1971
    Member
    Posted 3 weeks ago #

    Same exact thing for me on Azure. Just clicking settings, gives me the exact error. Guess, this plugin just does not work on Azure websites. Just like some other plugins. I don't think it likes MSSQL server. There is no solution that I can find for plugins not working for MSSQL databases.

  5. arnee
    Member
    Plugin Author

    Posted 2 weeks ago #

    I will see if I can get in running on Azure. What exactly are you running there? I'm not too familiar with it. Just a normal VM with IIS installed?

  6. hiddai
    Member
    Posted 2 weeks ago #

    Hi!

    My site in Azure is a free site connect to MSSQL DB.
    You can register and create up to 10 free sites.
    Click here and take a look how you can build a WordPress site in Azure Platform.

  7. hiddai
    Member
    Posted 2 weeks ago #

    from WZhaoMicrosoft (MSFT) Azure Web Site forum in MSDN:

    Hi Guys,

    This looks like a plugin compatibility issue. Please comment out line 127 in wp-includes\SimplePie\Item.php.

    /* Remove items that link back to this before destroying this object       */
    
                    public function __destruct()
    
                    {
    
                                    if ((version_compare(PHP_VERSION, '5.3', '<') || !gc_enabled()) && !ini_get('zend.ze1_compatibility_mode'))
    
                                    {
    
                                                    unset($this->feed);
    
                                    }
    
                    }

    It works for me after I commented out the red line of code.

    One more info:

    I was able to reproduce this problem on my local machine. So, this is not an issue specific to Azure Websites.

    The problem is reproducible as long as zend.enable_gc is set to off.

    So, you have another workaround which is set zend.enable_gc to on by putting a php.ini under your site's root folder.

    Regards,

    Wei

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.