WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Cleaner Gallery 0.6.1 showing limited number of images (9 posts)

  1. GATEKeeper
    Member
    Posted 5 years ago #

    Just upgraded to 0.6.1 of Cleaner Gallery and noticed that when the plugin is activated it's capping one gallery of 36 images to the first 10 (with the plugin off, the page shows all 36 images in the gallery).

    Since I don't see any setting in Cleaner Gallery for limiting, I'm guessing it's a mistake? Please let me know how to fix this.

  2. Justin Tadlock
    Member
    Posted 5 years ago #

    Seems to be working great for me on 0.6.1. Example:
    http://justintadlock.com/archives/2008/06/08/korean-folk-village

    I've also tested it with over 50 images just for the sake of testing and still working fine.

    Of course, you're always welcome to ask questions about the plugin on the plugin's support forum.

  3. GATEKeeper
    Member
    Posted 5 years ago #

    Even with every other plugin turned off, except cleaner gallery, the galleries are getting cut off at 10 images. There are 25 images in this gallery, and only 10 showing up.

  4. GATEKeeper
    Member
    Posted 5 years ago #

    Just FYI - I'm going to turn the plugin off until there's an update that fixes this. I'll wait until this evening so you have a chance to see the problem. (I love the plugin, by the way, but this is kind of a big issue for me.)

  5. GATEKeeper
    Member
    Posted 5 years ago #

    Well, that's weird. I thought this might something to do with it. If I go and change my "Reading settings" so that "Blog pages show at most" 20 entries - Cleaner Gallery shows 20 images.

    Any thoughts on how to fix? Obviously that setting should not be affecting the number of images being shown. And again, if I turn off Cleaner Gallery, all my images show up.

  6. GATEKeeper
    Member
    Posted 5 years ago #

    For anyone searching for the answer to this, I fixed it by opening the file cleaner-gallery.php and on line 177 where it says:

    'numberposts' => '',

    Change it to:

    'numberposts' => -1,

    This sets Cleaner Gallery to ignore the max number of items.

    Fantastic plugin, but for the record, I can't imagine why you would want your gallery to limit to the number of posts per page.

  7. Justin Tadlock
    Member
    Posted 5 years ago #

    I don't know where you got your version of Cleaner Gallery, but line 177 does not look like this:

    'numberposts' => '',

    It looks like this:

    'numberposts' => -1,
  8. GATEKeeper
    Member
    Posted 5 years ago #

    The last update I did through my site's admin panel downloaded the update and installed it. So, either I got a bad update from the auto install, or the version out there now is set to the way I mentioned above.

  9. Justin Tadlock
    Member
    Posted 5 years ago #

    You must've gotten some kind of bad install because this version:
    http://wordpress.org/extend/plugins/cleaner-gallery (0.6.1)
    uses -1 and not ''.

Topic Closed

This topic has been closed to new replies.

About this Topic